Go Down

Topic: [RESOLU]Atmega 1284p bootload via duemillanove en ISP (Read 613 times) previous topic - next topic

weetoz

J' ai tenté de regraver le bootloader optiboot_atmega1284p.hex,
et voici le retour d' erreur:
Code: [Select]
  This report would have more information with
  "Show verbose output during compilation"
  enabled in File > Preferences.
Arduino: 1.0.6 (Windows 7), Board: "Mighty 1284p 16MHz using Optiboot"
avrdude: Expected signature for ATMEGA1284P is 1E 97 05
         Double check chip, or use -F to override this check.


Alors que le retour monitor de atmega_board_detection donne:
Code: [Select]
Signature = 1E 97 06

Visiblement, j' avais gravé le mauvais bootloader.

Je pense que lorsque j' ai gravé la séquence d' initialisation, j' ai dû rester sur la carte UNO.


icare

#16
Dec 30, 2014, 09:48 pm Last Edit: Dec 30, 2014, 09:49 pm by icare
Bonsoir,
Celui là fonctionne : http://maniacbug.wordpress.com/2011/11/27/arduino-on-atmega1284p-4/
voir sous : Get the Software
2B OR NOT(2B) = FF
Arduino 1.0.5 + Notepad++ (sous Linux Fedora et/ou Windows)

weetoz

Bonjours,

me revoici avec un atmega tout neuf et enfin bootloadé!  8)


Voici le retour monitor du sketch atmega board detector de Nick Gammon:
Code: [Select]
Atmega chip detector.
Written by Nick Gammon.
Version 1.12
Compiled on Jan 21 2015 at 15:52:56
Attempting to enter programming mode ...
Entered programming mode OK.
Signature = 1E 97 05
Processor = ATmega1284P
Flash memory size = 131072 bytes.
LFuse = FF
HFuse = DE
EFuse = FD
Lock byte = CF
Clock calibration = 51
Bootloader in use: Yes
EEPROM preserved through erase: No
Watchdog timer always on: No
Bootloader is 1024 bytes starting at 1FC00


et celui de fuse_calculator:

Code: [Select]
Atmega fuse calculator.
Written by Nick Gammon.
Version 1.9
Compiled on Jan 21 2015 at 15:57:49
Attempting to enter programming mode ...
Entered programming mode OK.
Signature = 0x1E 0x97 0x05
Processor = ATmega1284P
Flash memory size = 131072
LFuse = 0xFF
HFuse = 0xDE
EFuse = 0xFD
Lock byte = 0xCF
Clock calibration = 0x51
OCD Enable.............................. [ ]
JTAG Enable............................. [ ]
Enable Serial (ICSP) Programming........ [X]
Watchdog Timer Always On................ [ ]
Preserve EEPROM through chip erase...... [ ]
Boot into bootloader.................... [X]
Divide clock by 8....................... [ ]
Clock output............................ [ ]
Bootloader size: 1024 bytes.
Start-up time: SUT0: [ ]  SUT1: [ ] (see datasheet)
Clock source: low-power crystal.
Brownout detection at: 2.7V.

weetoz

Malheureusement, je n' arrive pas à uploader le sketch blink...  :'(
Code: [Select]
avrdude: stk500_getsync(): not in sync: resp=0x00

J' enlève le 328p qui a servi d' arduino as isp, je câble comme suit:

Arduino             1284p
RX                    TX0    ( pin 15 )
TX                     RX0   ( pin 14 )
Reset                Reset ( pin 9   ) avec et sans résistance de pull-up, et j' ai aussi testé avec une capa de 100nF entre les deux broches resets.

Je me demande si il ne faut pas laisser le 328p sur l' Arduino avec le sketch arduino as ISP?

Si vous avez d' autre idées, n' hésitez pas!  :smiley-cool: 

weetoz

avec le 328p sur la duemilanove, ça ne fonctionne pas non plus:
avrdude: stk500_getsync(): not in sync: resp=0x0d
Mais le code d' erreur a légèrement changé!   :smiley-mr-green:

caape

Bonjour
En fait tu utilises le duemillanove sans le atmega328.
Tu connectes Rx avec Rx et Tx avec Tx.
En fin de compte, c'est comme si tu remplaces le atmega328 par le atmega1284. 
A+
StandAlone domotique<br />Volet roulant, Capteur T° sur p iles, (Eclairage Salon SAM en cour)(Pilotage via WEB + Mobile (base ok))(Sonnette)(Alarme)...

fdufnews

#21
Jan 21, 2015, 04:38 pm Last Edit: Jan 21, 2015, 04:46 pm by fdufnews
L'option low power crytal pose problème.
Les lignes RX et TX sont à coté de l'oscillateur et cela plante la carte.
Il faut utiliser l'option full swing oscillator.

Dans board.txt, pour le nom de carte que tu a défini, il faut changer l'option
xxxxxx.bootloader.low_fuses=0xff
par
xxxxxx.bootloader.low_fuses=0xf7

weetoz

#22
Jan 21, 2015, 04:47 pm Last Edit: Jan 21, 2015, 04:50 pm by weetoz
@ Caape:
C' est aussi ce que j' ai fait, mais rien n' y change.  ::)
Mais merci de t' intéresser.

@Fdufnews:

Merci, je vais tester ça illico, il faut rebootloader pour que le board.txt soit pris en compte?

fdufnews


weetoz

Effectivement, modification de board.txt,  fermeture de l' ide, réouverture  :smiley-mr-green:  rechargement du bootloader, upload du sketch et bing!! à vos souhaits!!

Merci Fdufnews,  8)
ça me motive à aller voir de plus près ces histoires de réglage de fuses, afin de me dispenser d' oscillateur externe.

Go Up