Pages: [1]   Go Down
Author Topic: Programming the Duemilanove from Ubuntu Hardy  (Read 628 times)
0 Members and 1 Guest are viewing this topic.
Georgia, USA
Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was so disappointed that I could not use my new board on Hardy directly due to problems with the compiler, so I found a great solution.  I installed Sun's Virtual Box on Ubuntu 8.04 and booted a copy of Ubuntu Jaunty (9.04).  From there I was able to load the required compiler, library and jre.

Quote
sudo aptitude install gcc-avr
sudo aptitude install avr-libc
sudo aptitude install sun-java6-jre
sudo aptitude remove brltty

I installed the Arduino software and brought up the GUI.  I plugged the board into the Hardy system and using the Devices/USB Devices menu in Vbox I was able to give control of the USB port to the GUI.  

I fired up the blink example from the Examples/digital menu on the GUI, did a Sketch/Verify/Compile, did a File/Upload and the led started to blink.

So for anyone frustrated trying to get a Linux box to work with the Arduino products that can't upgrade to the latest distro and can't get the latest gcc-avr running on their distro, here's a solution that is easy to implement.  I used the latest release of Vbox from the Sun site since the distro version is somewhat older.  

Just wanted to be sure this was documented somewhere.

Jim.
Logged

London
Offline Offline
Sr. Member
****
Karma: 0
Posts: 330
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


Thats exactly what I do as well.
Even though the machine Ihave has already got Jaunty on it with the correct tool chain.
It also means you can easily move the virtual machine to another pc if you ever need to with out breaking anything.
Dont foget you can take snapshots and roll back any changes you make to the tool chain if the changes you make dont work.

Gordon
Logged

Orygun
Offline Offline
Full Member
***
Karma: 0
Posts: 195
Don't let the smoke out!
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks for the post, this problem is one area where Windows and Mac people tend to have it a lot easier running the latest Arduino IDE supporting the latest ATMega chips. With Linux, since most of the stuff is native to the OS, and there are dependencies, you find yourself upgrading the OS every time there is a major change in the Arduino IDE and what it supports so you can get the latest gcc-avr...
Logged

Finland
Offline Offline
Sr. Member
****
Karma: 0
Posts: 270
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I just copied the needed packages from Debian Lenny. Installed without problems and worked perfectly on Hardy.
Logged

Dallas
Offline Offline
Sr. Member
****
Karma: 2
Posts: 337
nephew as a kittens
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I run Hardy UNR and managed to get the compiler that worked.

Can one run Arduino on a 64-bit system?



Logged

Georgia, USA
Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

As an experiment I installed an Ubuntu 9.04 template on a system running OpenVZ.  I loaded the Sun JRE.  The Arduino software didn't run due to some missing dependencies so I did the following:

Quote
aptitude install xauth
aptitude install libxtst6
aptitude install libxi6
aptitude install avr-libc
aptitude install  gcc-avr

I also had to add
Quote
DEVNODES="ttyUSB0:rw"
to the configuration for the VE so I could communicate with the board.

I then ssh'ed to the VE via
ssh -X 192.169.2.222
And ran the arduino script from the arduino-0017 directory and it worked.  I compiled and installed a modified version of blink to be sure it all worked as advertized.

I didn't really want to mess up my gcc install on Hardy by loading another gcc.  I didn't know what it might do and I do a lot of compiling on this system, so a virtual guest was the right thing for me to do.

Just FYI
Jim.
Logged

0
Offline Offline
Jr. Member
**
Karma: 0
Posts: 70
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No problems in the Ubuntu 9.04
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 49
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi.

If I were to do as you suggest and install a later version of Ubuntu in a VM to program the Arduino, would I still be able to send serial commands to it from another 8.04 machine once the Arduino code has been uploaded to the board?

I can't install a VM on the target machine as it's simply not gutsy enough, and I can't upgrade it as it has two other usb-relays (for lights etc..) in it that for some reason later kernels don't support.
Logged

Georgia, USA
Offline Offline
Jr. Member
**
Karma: 0
Posts: 80
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I see no reason that the IDE which is a JAVA app, I think, would not work on Hardy.  The only reason Hardy doesn't support it is because of a deficiency in the compiler/libraries.

OpenVZ doesn't take a lot of resources.  You might try it.  It has the smallest footprint of any of the virtual platforms that I'm aware of.  I didn't try QEMU but that might also be an option.

Jim.
Logged

Pages: [1]   Go Up
Jump to: