Go Down

Topic: Arduino 022 and OSC Lion (Read 908 times) previous topic - next topic

Hello,

Before I upgraded to OSX Lion on my MacBook Pro I had no problems with the Arduino IDE uploading sketches to my Arduino Uno. After upgrading, every time I try to load a sketch (any sketch) the whole arduino.app blows off. Here is a portion of the error message:

Process:         JavaApplicationStub [494]
Path:            /Applications/Arduino.app/Contents/MacOS/JavaApplicationStub
Identifier:      cc.arduino.Arduino
Version:         0022 (0022)
Code Type:       X86 (Native)
Parent Process:  launchd [127]

Date/Time:       2011-10-24 20:19:43.036 -0600
OS Version:      Mac OS X 10.7.2 (11C74)
Report Version:  9

Interval Since Last Report:          193722 sec
Crashes Since Last Report:           15
Per-App Interval Since Last Report:  4279 sec
Per-App Crashes Since Last Report:   15
Anonymous UUID:                      04566F11-174C-443A-A4F0-9C64E7DCD490

Crashed Thread:  27  Java: Thread-6

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000b21b8bf0


Has anyone else seen this behavior and more importantly have a fix for it. I'm in the middle of a new Arduino project and I have to get this working.

Any help would be appreciated.

I solved this myself. The problem was a mismatch in the RXTX library which I found by looking for upload errors in the system log with the Console.app. I copied the files from the Arduino 022 install

librxtxSerial.jnilib and RXTXComm.jar

over the files in /Library/Java/Extensions and my upload problems went away.


James C4S

Thank you for posting your actual fix and not just "oh I fixed it."  ;)
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy