Pages: 1 [2] 3   Go Down
Author Topic: 16x2 LCD backlight relay problem  (Read 3073 times)
0 Members and 1 Guest are viewing this topic.
Central MN, USA
Offline Offline
Tesla Member
***
Karma: 64
Posts: 6889
Phi_prompt, phi_interfaces, phi-2 shields, phi-panels
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Need some pictures of what are showing up on the LCD.
Logged


0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Here is a photo attached.



* IMG_20111122_110807.jpg (405.88 KB, 2048x1536 - viewed 25 times.)
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 25
Posts: 4108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

We have to know what should be showing up on the display as well as what is actually showing up on the display.

Are the results consistent.  In other words if you use the same initial (correct) message each time do you get the same (incorrect) message after the problem manifests itself?


Don
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes mate, what you're saying is what's happening.

I believe the LCD has some kins of problem! Reason being is that, I tested the same sketch with a blue 4x20 LCD and everything works as expected, left it for 2 hours, and everything shows perfectly.

Could it be the dreaded resistor for the LED?

Thanks.
Logged

Central MN, USA
Offline Offline
Tesla Member
***
Karma: 64
Posts: 6889
Phi_prompt, phi_interfaces, phi-2 shields, phi-panels
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I might shoot my foot by answering with pure speculation but it's easy to prove if I'm right or not: Disconnect the back light and see what happens (I know it's gonna be dark but you have desk lamps:))
Logged


0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Already tried that, garbage characters at start up smiley
Logged

Central MN, USA
Offline Offline
Tesla Member
***
Karma: 64
Posts: 6889
Phi_prompt, phi_interfaces, phi-2 shields, phi-panels
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Already tried that, garbage characters at start up smiley
Bang! my foot hurts.  smiley-cry

I have another foot for one more speculation: poor connection could do this too. Check your soldering and connections carefully.
Logged


Western New York, USA
Offline Offline
Faraday Member
**
Karma: 25
Posts: 4108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have some more questions to use in troubleshooting but you haven't responded to the previous ones.  Do you really want to get this fixed?  Oops - that's another question that probably won't be answered.

Don
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 25
Posts: 4108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
one more speculation...
You are shooting in the dark.

Don
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Already tried that, garbage characters at start up smiley
Bang! my foot hurts.  smiley-cry

I have another foot for one more speculation: poor connection could do this too. Check your soldering and connections carefully.

I've already checked the connections are all are fine!

Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have some more questions to use in troubleshooting but you haven't responded to the previous ones.  Do you really want to get this fixed?  Oops - that's another question that probably won't be answered.

Don

I'd love to get it fixed.

Here is how it should look like on each line:

Boost                            1  Bar
Oil T                             90 'C
Fuel                              10 Bar
Press                              2 Bar
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 25
Posts: 4108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That's one answer.  I don't have enough information to even take a guess yet.

Don
Logged

0
Offline Offline
Full Member
***
Karma: 0
Posts: 238
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

What else would you like to know mate?
Logged

Western New York, USA
Offline Offline
Faraday Member
**
Karma: 25
Posts: 4108
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
What else would you like to know mate?
Lots of things, but first I would like the answer to the question I have already asked.  This is like pulling teeth.

Don

(I am running out of idioms as well as patience.)
« Last Edit: November 22, 2011, 01:49:51 pm by floresta » Logged

Central MN, USA
Offline Offline
Tesla Member
***
Karma: 64
Posts: 6889
Phi_prompt, phi_interfaces, phi-2 shields, phi-panels
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

After answering question from floresta, also consider posting your code. You can test the LCD with some sample LCD sketches in arduino. Your picture shows partial text of what you intended to print with a lot of junks in between, including a strange blob. The blob makes me suspect your program. It is character 0 to 7 so it only prints out when you send 0 to 7 to the display.
Logged


Pages: 1 [2] 3   Go Up
Jump to: