Pages: [1]   Go Down
Author Topic: timing problem for my hydroponic system  (Read 426 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

im an electronics enthusiast but not smart in programming  smiley-cry . i am running a water pump for my hydroponics system (variable on and off timing) with various water level and temperature sensors. my problem is i can't run the on and off timing of the pump and the sensors simultaneously.The only way i know is the delay command which is not suited for my needs.  I'm really a newbie, any suggestion will be much appreciated. thanks in advance  smiley
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
The only way i know is the delay command which is not suited for my needs.
You need to look at the blink without delay example.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 16
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Use millis() instead of delay.. Have a look at my last post. http://arduino.cc/forum/index.php/topic,77152.0.html
This is altso used for a gardening system.. but with soil.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 41
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

thanks a lot guys.  smiley perfect  smiley-grin arduino is awesome!!!!
Logged

Pages: [1]   Go Up
Jump to: