Pages: [1]   Go Down
Author Topic: Windows 7 (64 bit) USB Serial port probs with OSEPP board  (Read 3404 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I plugged in a new Uno for the first time to my Windows 7 (64 bit) box and it automatically installed the driver and seemed happy.
Port 3 now shows up in the Arduino IDE with the Uno plugged in and goes away with it unplugged. However, I get the infamous:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


When trying to run "Blink"

Under "Driver Manager" port 3 shows up as "USB Serial Port (COM3)"
Following the trouble shooting guide and doing a driver update and pointing to the Arduino Drivers directory Windows keeps saying:
"The best driver software for your device is already installed"
"Windows has determined that the driver software for your device is up to date"
"USB Serial Port"

I even downloaded the latest driver from FTDI and get the same thing.

Even when I do an uninstall and plug the Uno back in it reinstalls the same driver and repeats the same errors. I do an uninstall and have it remove the files - same thing. Windows seems to be 100% happy with the driver - I can't seem to update the driver and upload the blink app. Lights are all on the Uno, good cable etc.

Any advice would be most appreciated.
« Last Edit: November 03, 2011, 11:12:11 am by mellis » Logged

Slovakia
Offline Offline
Newbie
*
Karma: 0
Posts: 33
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Have you selected UNO in Tools/Boards ?
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes, Uno is selected.
One thing to note is that this is a OSEPP Uno from Fry's Electronics - says "Arduino Compatible"

Also, from the instructions, two thing were different:
Plug in your board and wait for Windows to begin it's driver installation process.  After a few moments, the process will fail, despite its best efforts

Mine did not fail but found a driver and Windows said the device was ready

Look under Ports (COM & LPT).  You should see an open port named "Arduino UNO (COMxx)"


With the Uno plugged in, I get a COM 3 showing up but it's not named "Arduino UNO (COM3)"
It's named "USB Serial Port (COM3)" and no matter what I do to update that, Windows always says "The best driver software for your device is already installed"
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 3
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Got it working - on the OSEPP site:
http://osepp.com/learning-centre/start-here/osepp-uno-arduino-compatible/

You have to select a different board:
c.     Select the Duemilanove board: Tools > Board > Arduino Duemilanove or Nano w/ ATmega328

The reason for selecting the Duemilanove board instead of the Uno board is due to a known bug in the Uno bootloader. Don’t worry, the functionality is the same!


Yeah!
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Thanks so much, I was having this same problem with the OSEPP Uno on my Mac (Lion), I chose the "Arduino Nano w/ATMega 328" on port /dev/tty-usbserial-A900H28R and it worked like a charm.

Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm using 32-bit XP and I can't get this stupid thing to work.. OSEPP Uno Board

the only driver installed was a "USB Serial Converter" but nothing for the board I guess?


in the device manager I have a "USB Serial Port" (with an exclamation point) that came up under "Other Devices" I can't get a driver to load for it, it keeps saying the driver is not needed or that the driver dose not contain information about my hardware.

I tried ALL of the board options in the list, I also only have "COM 1" option in the Serial Port List....

I joined the OSEPP forum but I'm still waiting on someone to approve my membership and it taken awhile already.

I have no other ideas at this point..

Oh, I also get the: avrdude: stk500_getsync(): not in sync: resp=0x00

thanks...
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 30
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Well I had to manually install it as a COM port, then Update the Driver, and the updated driver was in the FTDI USB Drivers directory..

now I have a blinking light smiley-grin
Logged

Pages: [1]   Go Up
Jump to: