Go Down

Topic: Faire cohabiter Teleinfo, 1 wire et serial monitor (Read 1 time) previous topic - next topic

aquadiscount

Bonjour,

j'essaie de faire un programme qui m affiche la consommation instantanée teleinfo et la température d'un capteur 1wire.

Afficher la teleinfo seule , pas de souci.
Afficher la température 1 wire seule, pas de souci.

Mais faire cohabiter les 2 codes, marche pas !!!

Je suis débutant, il y a surement quelque chose qui m échappe ...

Le teleinfo c'est une liaison série, initialisée en 1200 baud et UCSR0C = B00100100;  parité paire E, 7 bits de data

Est ce que ce serait ça qui gênerait la communication 1wire par la suite ? Mon capteur est sur une entrée digital 22 , je suis sur une mega

Merci de me guider !

++

Artouste

#1
Nov 04, 2011, 12:32 pm Last Edit: Nov 04, 2011, 02:02 pm by Jean-François Reason: 1

bonjour
Ce n'est pas clair comme description des symptomes
déjà est ce que ça marche avec le même code pour le teleinfo seul et le 1-wire seul ?
ou ce sont des codes différents utilisés ?



aquadiscount

Salut,

j'ai un shield teleinfo de cartelectronic qui marche nikel, avec le code qui va bien.

Le souci est que ce que me crache le serial monitor est illisible, alors que dans n importe quelle appli pas de souci.

Comme faire pour bien voir les trames ?

Merci

Artouste


Salut,

j'ai un shield teleinfo de cartelectronic qui marche nikel, avec le code qui va bien.

Le souci est que ce que me crache le serial monitor est illisible, alors que dans n importe quelle appli pas de souci.

Comme faire pour bien voir les trames ?

Merci

C'est difficile d'être coopératif avec des infos aussi  parcellaires  :D
liens vers
le(s) materiel utilisé
le(s) codes

et... vous n'avez pas repondu à ma question simple plus haut :

Quote
déjà est ce que ça marche avec le même code pour le teleinfo seul et le 1-wire seul ?
ou ce sont des codes différents utilisés ?


ft77

Bonjour.

Je crois que le module Cartelectronic utilise justement le port série pour s'interfacer avec l'Arduino.

Cela signifie que sur le port USB de ton Arduino, qui reprend en fait la liaison série via un circuit (FTDI je crois, mais qu'importe), tu vas "voir" les données échangées entre le shield teleinfo et l'Arduino.
Par contre cela veut aussi dire que des instructions type Serial.print vont envoyer des données à la carte teleinfo, qui risque de ne pas comprendre! Et une instruction Serial.begin() va configurer une vitesse qui ne sera pas celle prévue pour la teleinfo...
Cela pourrait expliquer un mauvais fonctionnement, mais tu devrais déjà avoir le problème avec le teleinfo seul, ce qui n'est pas le cas?

Maintenant, en ajoutant le module OneWire, s'il est sur un port différent, il ne devrait pas perturber. Par contre là encore quand tu envoies les données de ce dernier vers le PC, tu vas encore passer par la même liaison série que celle utilisée pour le Teleinfo.

Effectivement, mets ton code en ligne, qu'on puisse te répondre sur une bonne base...

Plus globalement pour le module teleinfo, l'idéal serait de l'utiliser sur un port série différent (je crois que la Mega en a plusieurs).

Bon courage!

Go Up