Pages: [1]   Go Down
Author Topic: sync error with arduino pro mini  (Read 1103 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 1
Posts: 130
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello, I recently bought an Arduibo pro mini and a usb board to connect it to the computer:
http://www.geeetech.com/index.php?main_page=product_info&cPath=42&products_id=204
but whenever I try to upload ANY sketch I get the following error:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

when the board is connected(properly) the power light(green light) is on and another light(red) blinks about once a second

my board was sold by geeetech, I am using windows 7 and mac os x 10.7 beta, arduino pro mini ATMega168 5v/16hz
I connected the board to the usb board like the website I bought it from explained, I will upload a picture if neccessery
« Last Edit: April 17, 2011, 05:34:01 am by tomer1510 » Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 15
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

I had exactly this problem with exactly this board (from geeetech.com). I also sometimes got "stk500_getsync(): not in sync: resp=0x00" repeated twice, but uploading always failed.

The solution was to set the board type to "Arduino Diecimila, Duemilanove or Nano w/ ATmega168" (In the Arduino IDE, look under Tools -> Board). Then it worked like a charm for me.
Logged

Pages: [1]   Go Up
Jump to: