Go Down

Topic: Serial Port 'COM3' already in use. (Read 5188 times) previous topic - next topic

emilyskopp

My arduino does not connect to my computer.  I get the error "Serial Port 'COM3' already in use. Try quitting any programs that may be using it."  This happens even on a fresh restart.

How do I fix this?

baum

Are you sure that you have the right COM port? And what Arduino do you have?

baum

j514

in the arduino editor select:

Tools/Serial Port/Com5

unplug your arduino, restart the editor, then plug your arduino back in.
hope that helps.
a][+ ascii express, 110/300 novation cat, xmodem

emilyskopp

Mega.

Yes, correct serial port is selected hence it says that the serial port is occupied.

Can we assume that I've done everything right, and this is only about getting the two to communicate.

baum

Have you installed the FTDI drivers or the atmega8u2 .inf file? If not, windows may think that the mega is something else...


baum

WizenedEE

Yes, correct serial port is selected hence it says that the serial port is occupied.

Or maybe it's occupied by another device, like bluetooth.

I usually get that message when I open a serial port (in another programming language) and don't close it. There could be other programs that scan all serial ports (looking for bluetooth devices, for example) and don't end up closing them. What's your operating system?

Can we assume that I've done everything right, and this is only about getting the two to communicate.


Oh, you've done everything right? Okay, don't need our help then.

emilyskopp

My computer doesn't have Bluetooth.  Windows 7.

emilyskopp

I've done this before on Linux.  It worked like a charm.  Now I have a new computer on Windows 7. 

I have done everything correctly.  Don't judge.  I just can't control which ports are being used by which devices.

baum

What if you change ports? you do have >1 USB port, right?

K5CZ

If port is in use, open the Device manager, disable port and then enable port. This unlocks the port.
Arduino Uno R3, Arduino Mega 2560 R3, Ethermega (R3), and some Ethernet Shields (R3), Chronodots, TMP36 sensors, DS18B20 sensors, LCDs/TFTs, RS232C to learn and play...

Carthaginian


If port is in use, open the Device manager, disable port and then enable port. This unlocks the port.


Just a quick note (since I'm having a similar problem).  When I disabled the port, I had to restart the computer before it would be enabled again.  Once the computer rebooted, nothing different happened.  It didn't work.

eried

Maybe this solves your issues http://forum.arduino.cc/index.php/topic,118440.0.html (old avrdude left my port in use with some cheap mega2560 clones)
My website: http://ried.cl

Carthaginian

The OP and I are dealing with a similar problem, and we have at least one thing in common:

We originally used our boards with Linux.  Everything worked fine then.  Then we moved to Windows 7 (and I assume with the same boards) and started having problems.

At least in my situation, could Linux have messed with the ports?  Any other ideas?

Carthaginian


Maybe this solves your issues http://forum.arduino.cc/index.php/topic,118440.0.html (old avrdude left my port in use with some cheap mega2560 clones)


I tried this other software and got the same error.

eried



Maybe this solves your issues http://forum.arduino.cc/index.php/topic,118440.0.html (old avrdude left my port in use with some cheap mega2560 clones)


I tried this other software and got the same error.


mmm so I think your problem is another application running in your machine. I can try to help you if you want via teamviewer
My website: http://ried.cl

Go Up