Pages: [1]   Go Down
Author Topic: How to use blank atmega8 in a uno board ?? ?  (Read 826 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Friends i need help in boot loading atmega 8 to use it in uno board.

I tried optiboot also but i got the error message " avrdude yikes invalid device signature" . I followed connections as per arduino as ISP. And added 10uf capacitor between ground and reset . I modified my boards.txt files also. But no use . Can any one suggest me step by step instructions to bootload Atmega8 so that it can be used in my uno board.
Please help me  .................
 


                                TAHNKS IN ADVANCE.........................
Logged

Massachusetts, USA
Offline Offline
Tesla Member
***
Karma: 212
Posts: 8967
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

You got really close.  If you selected the "Arduino UNO" board when burning the bootloader the problem is that the ATmega8 signature doesn't match the expected ATmega328P signature.

The easiest thing to try is to select the "Arduino NG or older w/ ATmega8" board.  This will burn an older bootloader but it should work with your chip.
Logged

Send Bitcoin tips to: 1L3CTDoTgrXNA5WyF77uWqt4gUdye9mezN
Send Litecoin tips to : LVtpaq6JgJAZwvnVq3ftVeHafWkcpmuR1e

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

s john i tried that too but no use i get the same error message..............
Logged

Norfolk UK
Offline Offline
Faraday Member
**
Karma: 70
Posts: 2587
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have a couple of ATMega8's that used to have fuse settings and bootloader to suit 16Mhz crystal. I have attached the bootloader I used but I cannot remember what the fuse settings were of find the forum that discuses them. Here http://www.ngcoders.com/downloads/arduino-atmega8-bootloader-2-second-autoreset/ is a link to another bootloader. I have since re-programmed the chips for internal 8Mhz oscillator use so cannot read fuse settings from them.

You say in your original post these are to be placed in your UNO board. I think the mega8 pinouts are the same as the 328 chip but the architecture is different, not sure if this will cause problems.

* atmega8_19200_16M.zip (1.35 KB - downloaded 10 times.)
Logged


Pages: [1]   Go Up
Jump to: