Go Down

Topic: Opel TID Display (Read 29483 times) previous topic - next topic

AJB2K3


Thanks for the OpelTID library
Unfortunately I've tried to use it, but it's not working.

I'm using the following code, and the only thing I see is sometimes a CD symbol  : http://pastebin.com/2jHE4zxh
I can change the symbol by changing the the value of  i
But I'm not seeing any text.

I'm using a UNO R3 and i've tried 2 TID.
What I'm doing wrong ?

Roel



A cd symbol?

Please post pics of you setup? my TID has no cd symbol.
Sorry for the noobish post but my knowledge is 10 years out of date!

bobale

#31
Jan 13, 2013, 03:00 pm Last Edit: Jan 13, 2013, 03:02 pm by bobale Reason: 1
Roelke, which Opel do you have?

roelke

@AJB2K3 The 10 symbols on the top of the display.
I will make some pictures tomorrow.

@bobale It's a Opel Astra F 1.4 build in 1994.


AJB2K3

Were working on the Astra G/corsa C/ Vectra C version.

Have you tried
https://www.box.com/s/lskrsqwboezr8f7efnop
Sorry for the noobish post but my knowledge is 10 years out of date!

roelke

As I already noticed in my first post, i'm using the OpelTID library.
I'm using offcourse the 1.1 version.

Giovanni83

taking for granted that you have already checked your connections throughly, first thing you should try is changing the string from "hello" to "HELLO" since the display can't display lowercase characters  XD. Another curios thing about this display is that every minute the screen is cleared of all symbols and characters (this is done by the display itself, not by my library, and i don't know if it's possible to avoid this), so since your sketch includes a 2s delay, the only symbol shown goes away for up to 2 seconds from time to time. BTW, all other symbols are working too? if you assign i=1 you see the dolby c and so on?

hope this was helpful

AJB2K3

Giovanni83, Can I ask you an odd question?

Whats the IC numbers in you clock as I can't find any info of the chip in mine?
Sorry for the noobish post but my knowledge is 10 years out of date!

Giovanni83

Quote
Whats the IC numbers in you clock as I can't find any info of the chip in mine?


the main ic is a ST6 microcontroller, from what i gathered here it's a ST6240B that is factory-programmed, so the number on the chip (ST624306/A2) shows nothing when searching for datasheet.

AJB2K3

Interesting, mine reads
40376-00
980 P1B65004PJ
F21-33A5EEW
Sorry for the noobish post but my knowledge is 10 years out of date!

AJB2K3

Ok something interesting on the data sheet, it's SPI!
Sorry for the noobish post but my knowledge is 10 years out of date!

Giovanni83

Quote
Interesting, mine reads
40376-00
980 P1B65004PJ
F21-33A5EEW


not a single number corresponding on mine, so... no idea :smiley-red:

Giovanni83

I'm wondering if the solution worked for roelke



also, i would know if there are other places were i could post infos on this library to let more people know it's there.

AJB2K3

#42
Jan 19, 2013, 06:09 pm Last Edit: Jan 19, 2013, 06:20 pm by AJB2K3 Reason: 1
Do you have a blog?
Have you tryed hackaday?
I would dry AOC (Astra Owners Club but don't know my password.
EDIT: Back into the forum and just spread the word.
Sorry for the noobish post but my knowledge is 10 years out of date!

Giovanni83

Quote
Do you have a blog?
Have you tryed hackaday?
I would dry AOC (Astra Owners Club but don't know my password.
EDIT: Back into the forum and just spread the word.


i don't have a blog but i will try hackaday, thanks for the suggestion.

AJB2K3

Out of blind curiosity..... Did the i2c scan sketch work with the TID?
Sorry for the noobish post but my knowledge is 10 years out of date!

Go Up