Go Down

Topic: Opel TID Display (Read 27 times) previous topic - next topic

Giovanni83

if you mean this sketch, i just tried: keeps saying "no i2c devices found"

AJB2K3


if you mean this sketch, i just tried: keeps saying "no i2c devices found"



Yup thats the one.
Hmn not good then.
Thanks for answering yet another daft question.
Sorry for the noobish post but my knowledge is 10 years out of date!

dandymon


Were working on the Astra G/corsa C/ Vectra C version.

I'm very thankful for the lib creators - top work!
I've made a modification for my Astra F with the 10 character display - some differences/error in the original for this.
src:http://web.archive.org/web/20100929182320/http://www.eelkevisser.nl/fabio.html
Code: [Select]
void TID::cycle(){
start_tid();
tid_address();
tid_data(_SYMBOLS1);
tid_data(_SYMBOLS2);
tid_data(_SYMBOLS2);// needs three sets of symbols for the 10 digit display
for (int i=0; i<10;i++){ // <<<<<<<needs to cycle up to 10!!!
tid_data(_display[i]);
};
stop_tid();
}

(plus some other variables i've exttended)
and there was an error in the code, it said 0x9A where 0x9B is needed
Code: [Select]
tid_byte(0x9B); //the address for the 8 char display is embedded here, for the 10 char you have to use 0x9A <<wrong

Next up, SD interface for in-car MP3 player!

Daniel Crane


Giovanni83


and there was an error in the code, it said 0x9A where 0x9B is needed


really? i read everywhere that the 10 char version needed 0x9A... oh well.

Great job fixing the library for this version of the display, i was interested in doing so myself, but i have only an 8 char version so it would had beed hard to check if everything was properly working. Thanks for your contribution, have fun with your project!  :)

gorgeous

Hi there,

I bought myself an Arduino Nano for displaying the current speed in my Corsa C with 10 letters display.
At first I simply extended the .ino file from the first page. But nothing happend. Then I tried the lib from dandymon by running the example. But still nothing is happening. Im using this code:

Code: [Select]
#include <TID.h>
//Created by Daniel Crane
TID mydisplay(3,4,5);//SDA, SCL, MRQ

void setup()
{
  pinMode(13,OUTPUT);
}

void loop()
{
    mydisplay.display_message("SCROLLING MONKEY5!",500);
    digitalWrite(13,HIGH);
    delay(500);
    digitalWrite(13,LOW);
    delay(1000);
 
}

I've connected SDA to D3, SCL to D4 and MRQ to D5. But even the LED L on the board doesnt light. When uploading the basic blinking sketch from Arduino examples, the LED starts to blink right after uploading.

I've experienced another problem. When connecting a 12V= powersource to VIN, the LEDs RX and TX start to light, but even the blinking sketch doesn't start to blink LED L. Only if I connect 5V= via USB from a power supply for mobile phones, L starts to blink.

Im using Arduino 3.0 and Im new to Arduino, but Im very experienced writing C-code. Im not too familiar with C++.

Go Up