Go Down

Topic: Need Help with TQFP-44 version of 1284P bootloader (Read 1 time) previous topic - next topic

Constantin

Hi everyone,

I decided to implement a 'Arduino-compatible' board using the TQFP-44 version of the 1284P-AU Atmel CPU. The pinouts are identical to the Bahbots controller, but I am having no luck getting the bootloader uploaded. The only difference between the Bahbots implementation and mine is the clockspeed, i.e. my chip runs at 16MHz, vs. 18.432MHz for the Bahbot. I modified the boards.txt file as follows:

Code: [Select]
arduino_bahbots1284p.name=Arduino-BahBots 16MHz
arduino_bahbots1284p.upload.protocol=stk500v2
arduino_bahbots1284p.upload.maximum_size=122880
arduino_bahbots1284p.upload.speed=115200

arduino_bahbots1284p.bootloader.low_fuses=0xFF
arduino_bahbots1284p.bootloader.high_fuses=0xD8
arduino_bahbots1284p.bootloader.extended_fuses=0xFF
arduino_bahbots1284p.bootloader.path=bahbots
arduino_bahbots1284p.bootloader.file=BootLoader-m1284p.hex
arduino_bahbots1284p.bootloader.unlock_bits=0x3F
arduino_bahbots1284p.bootloader.lock_bits=0xFF

arduino_bahbots1284p.build.mcu=atmega1284p
arduino_bahbots1284p.build.f_cpu=16000000L
arduino_bahbots1284p.build.core=arduino


I also tried the stk500V2 bootloader that came as part of Mark Sproul's excellent archive. No joy there either. I wonder if enough changed between version 20 of the Arduino software and the current 22 revision that I am using now for that to break something?

Anyhow, my symptoms are pretty simple: I fire up the Arduino IDE to burn the bootloader. The USBTiny upload seems to work fine - the SCK-activity light blinks merrily away. Then it turn steady (on) before turning off and the Arduino ide reports the following error:
Code: [Select]
avrdude: verification error, first mismatch at byte 0x1e000
         0x0c != 0xff
avrdude: verification error; content mismatch


So what could I be doing wrong?

Constantin

Oh, and I should mention that the board also has a 328P microcontroller on it. This little guy is designed to communicate via newsoftserial with the bigger Atmel processor. The only other connection between the chips is a shared reset connection. Other than that, they are completely separate. What I do notice though is that as the Bootloader for the 1284P is uploaded, the sck-activity light for the 328P stops blinking. That said, I doubt this is the issue since I was able to upload the bootloader for the 328P just fine.

westfw

Are you sure that USBTiny supports chips with more than 64k of program memory?  It's an easy thing to get wrong.
http://forums.adafruit.com/viewtopic.php?f=20&t=14752&p=72377&hilit=128k#p95438
(I don't know how old that discussion is WRT current product...)

stratosfear


Constantin,

I also tried the Bahbots bootloader and cores on a 1284.  The bootloader installed correctly and programs would compile, but uploads would halt without an error message.  My best results use a mix of brewtroller's bootloader/cores and Arduino-0022 cores.  The procedure can be found in the last post of this thread.  I've got no idea how this would affect your pin definitions, since my application was for a Sanguino.

Jon

Constantin

#4
Nov 14, 2011, 07:43 am Last Edit: Nov 14, 2011, 03:28 pm by Constantin Reason: 1
You guys are the best. First of all, I stopped pulling the few of my remaining hairs out. With the help of the link you provided, I was able to confirm that the TinyISP cannot write a bootloader for any device with over 64kB of Flash memory. Even better, I was able to convince Adafruit to prominently mention on the TinyISP web store page that such devices are not supported so others don't follow in my footsteps.

In the meantime, I am waiting for the AVRII programmer from Atmel... I hope that the cores that Mark Sproul put together will work... I also made sure to download Arduino 23, and then I replaced the AVR section with the latest version of WinAVR. So now I should be ready for my shipment from Digikey... Thank you again, I really appreciate the help.

Go Up