Pages: 1 [2]   Go Down
Author Topic: Problemes ecriture et lecture eeprom Arduino Mega 2560  (Read 1806 times)
0 Members and 1 Guest are viewing this topic.
France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Par contre il me reste plus qu'a rassembler tout ce beau monde avec l'ajout d'un dernier bout de code qui est le fichier ha.pde, ma question peux tu me donner le dernier coup de main pour inserer ce code dans le fichier final qui est adi_main.pde car j'ai essayé mais le resultat final est delirant car je n'arrive pas a placer ce code au bon endroit sur le code existant.
J'ai essayé de te faire un mix des deux code, par contre je pense qu'il faudra peut être commenter #define SERIAL_ON de adi_main.h pour éviter d'avoir des problémes avec le port série (mais pas sur).
J'ai pas pu compiler ton code (j'avais pas la RTClib) donc il faudra que tu test par toi même smiley-wink

* adi_main.zip (14.33 KB - downloaded 9 times.)
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Draguignan (Var)
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
Arduino, voila une bonne invention...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci Skywodd j'essai et je te tiens au courant, sinon voici la librerie RTCLib si tu veux essayer
Fred

* RTClib.zip (2.59 KB - downloaded 7 times.)
« Last Edit: February 07, 2012, 04:42:13 pm by Alfredo Ingrassia » Logged

Draguignan (Var)
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
Arduino, voila une bonne invention...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Salut Skywodd, merci ton mix, par contre il me perturbe le calibrage du 6DOF (Horizon Artificiel)... Au demarrage il me fait delirer l'altimetre qui monte puis il descend.

Normalement a la mise sous tension l'afficheur me donne Pression: 1018 [  315Ft] par contre moi maintenant j'ai Pression: [    0Ft] puis l'altimetre delire...

Cependant j'ai remarqué que si je met Calibrate(); en commentaire il refonctionne correctement a mon avis Calibrate(); est sur un mauvais endroit dans le code..qu'n penses tu ?
   
/* MODIF HA.PDE */
  delay(300);                 // Attente avant la "Mise en route"
  Calibrate();                // Calibrage des Capteurs IMU 6DOF
  pre_time = millis();        // Mise en mémoire de l'heure pour calcul du temps "précédent" 


Je me tate si je vais pas mettre deux Arduino UNO un pour l'altimetre, vario etcc l'autre pour le gps et l'horizon artificiel peut etre le fait de les separer marchera avec precision et sans perturbations...c'est bete parce que le 2560 a toutes les entrées necessaires pour l'ensemble.
« Last Edit: February 08, 2012, 12:52:49 pm by Alfredo Ingrassia » Logged

France
Offline Offline
Faraday Member
**
Karma: 55
Posts: 5347
Arduino Hacker
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Cependant j'ai remarqué que si je met Calibrate(); en commentaire il refonctionne correctement a mon avis Calibrate(); est sur un mauvais endroit dans le code..qu'n penses tu ?
La calibration se fait peut être autre par, je sais pas ... si une fois en commentaire ça marche autant y laisser comme ça.
Logged

Des news, des tuto et plein de bonne chose sur http://skyduino.wordpress.com !

Draguignan (Var)
Offline Offline
Jr. Member
**
Karma: 0
Posts: 71
Arduino, voila une bonne invention...
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Merci Skywodd, je vais tester sinon je vais opter pour 2 arduino..La bonne soirée a toi et encore merci
Amicalement Fred
Logged

Pages: 1 [2]   Go Up
Jump to: