Go Down

Topic: ds1620 on mega2560r3/1.0.3 on mac, library wont compile (Read 362 times) previous topic - next topic

pyrotuc

when i try to compile the example in ruben lagunas ds1620 library i get strange errors that im not sure how to fix

/Users/kristucker/Documents/Arduino/libraries/ds1620/ds1620.cpp: In member function 'void Ds1620::rst_low()':
/Users/kristucker/Documents/Arduino/libraries/ds1620/ds1620.cpp:127: error: 'LOW' was not declared in this scope
/Users/kristucker/Documents/Arduino/libraries/ds1620/ds1620.cpp:127: error: 'digitalWrite' was not declared in this scope


can anyone point me in the right direction? im thinking it was written for a old version of the compiler and needs to be updated, but im not sure how to do it. ive gotten tons of other code to run with little to no problems... frustrating!

pyrotuc

nevermind, i ditched that library and found a newer one that works.

https://github.com/msparks/arduino-ds1620

i only managed to pull half my hair out, luckily.

Go Up