Go Down

Topic: NewSoftSerial & servo jitter (Read 516 times) previous topic - next topic

epossum

Hello,

Have anybody expierienced servo jitter using NewSoftSerial?
When a byte comes in servo jerks a bit ...

NSS pins = NewSoftSerial wrtserial(2, 4);
Servo on = const int servoPin = 9;
Normal servo lib = #include <Servo.h>

Any ideas?

Janis

cr0sh


Hello,

Have anybody expierienced servo jitter using NewSoftSerial?
When a byte comes in servo jerks a bit ...

NSS pins = NewSoftSerial wrtserial(2, 4);
Servo on = const int servoPin = 9;
Normal servo lib = #include <Servo.h>

Any ideas?

Janis


Here's an idea - look up at the top-right of the forum - see that search box? Type in "servo jitter" and press return. I guarantee that you will find information on this very problem. Here's another: Do the same on the old forum:

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl

This is an issue that has been experienced by a lot of people in the past; I can't tell you if there is a real solution - but doing a bit of research before you ask about it may help.
I will not respond to Arduino help PM's from random forum users; if you have such a question, start a new topic thread.

epossum

Thank's for the lesson of good manners, kind Sir! :)
I forgot that Google search is not indexing every post in old and new forums.

Solution was to use old servo library not conflicting with NSS interrupts.

Janis

Go Up
 


Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

Arduino
via Egeo 16
Torino, 10131
Italy