Go Down

Topic: USB Port selection (Read 754 times) previous topic - next topic


Is the Arduino showing up as a COM port in Device Manager?

James C4S

Yes same COM3 shows up and I can't select anything else as it is frozen . Thanks for the

Okay so now you know that COM3 isn't the Arduino.  No point in trying to program it.  The IDE only lists the com ports that Windows tells it.  If the IDE doesn't see the Arduino it is because your operating system doesn't either.

You are installing the FTDI drivers, correct?

What you plug the board in, what shows up in Device Manager?

Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com


Hi James & magnethead,
                               When I plug the board there is no change in the device manager. Also when I tried the Arduino board on a Netbook opering on Win7 it  works perfectly. It shows serial port as COM4 . But it is a lot slower .It takes several minutes to load and execute even a small program like Blink' . That is why I wanted my desktop to interface the board. So based on my above observations I think the problem is with my desktop OS (vista). Any suggestions how to rectify it? Thanks for your time.

With regards,


              Can anybody please tell me how to reset my USB COM Ports without again reinstalling my Windows operating system (Vista) Thanks in advance .


Hi Everyone,
                         At last I was able to sort out the problem . I went to the device manager and reinstalled the driver for (FTDI device) while the Arudino board was connected to the USB port. Now it is fine and working as before. Thanks to all people who tried to help me .


Go Up