Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 386833 times) previous topic - next topic

Jantje

Which one is the recommended tool?
Depends on who you ask the recommendation. Given this is a Sloeber thread the recommendation here is Sloeber :-)
 
But I'm still interested about your thoughts on why using Sloeber.
My thoughts on this subject (not having been able to get "Eclipse C++ IDE for Arduino" to work ever).
The main reason to use Sloeber is that it is supported far better.

Basically I bother to ...
1) write documentation and make video's on how to
2) test boards/setups I don't use. (currently more than 500 boards compile the default ino successfully out of the box)
3) be responsive when there are issues.
4) be even more responsive to people who support me on patreon https://www.patreon.com/jantje

IMHO this makes the end user experience far better because
1) I limit my response efforts by fixing issues
2) If there are issues there is help available

I'm trying to find out since hours the differences between Sloeber V4 and Eclipse C++ IDE for Arduino 3.0.
Both tools are build on top of CDT and as such have at least 95% the same functionality.
The differences are only at the level of
1) implementation/integration differences of the arduino framework -Sloeber supports multiple versions of the same platform at the same time -
2) specific boards features -like esp debug info-.
3) What is included in the package. Sloeber product comes with everything you need to do hardware/software debug
4) Add on functionality/integrations like the x-y plotter and serial monitor
5) Support for boards which do not come in a json package (like teensy)

This is my opinion. Please share yours :-)

Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

VicomtedeValmont

Thanks for your extensive response, Jantje. I'm convinced now and will start using Sloeber. I was confused since the Arduino IDE 3.0 was preinstalled in the latest version of CDT. But Sloeber works perfectly. Good work!

mAzharIqbal

Hi,
I am facing an issue in using ESP8266.
Arduino Nano works fine. But no example compiles for any ESP8266. I have installed ESP8266 board manager v2.4.2.


12:52:44 **** Incremental Build of configuration Release for project genericesp ****
"C:\\eclipse\\arduinoPlugin\\tools\\make\\make" all
'Building file: ..\sloeber.ino.cpp'
'Starting C++ compile'
"C:\eclipse\arduinoPlugin\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++" -D__ets__ -DICACHE_FLASH -U__STRICT_ANSI__ "-IC:\eclipse\/arduinoPlugin/packages/esp8266/hardware/esp8266/2.4.1/tools/sdk/include" "-IC:\eclipse\/arduinoPlugin/packages/esp8266/hardware/esp8266/2.4.1/tools/sdk/lwip/include" "-IC:\eclipse\/arduinoPlugin/packages/esp8266/hardware/esp8266/2.4.1/tools/sdk/libc/xtensa-lx106-elf/include" "-IC:/Users/azhariqbal/eclipse-workspace-arduino/genericesp/Release/core" -c -Wall -Wextra -Os -g -mlongcalls -mtext-section-literals -fno-exceptions -fno-rtti -falign-functions=4 -std=c++11 -MMD -ffunction-sections -fdata-sections -DF_CPU=80000000L -DLWIP_OPEN_SRC -DDEBUG_ESP_PORT=Serial -DDEBUG_ESP_CORE -DARDUINO=10802 -DARDUINO_ESP8266_GENERIC -DARDUINO_ARCH_ESP8266 -DARDUINO_BOARD="\"ESP8266_GENERIC\"" -DLED_BUILTIN=11  -DESP8266   -I"C:\eclipse\arduinoPlugin\packages\esp8266\hardware\esp8266\2.4.1\cores\esp8266" -I"C:\eclipse\arduinoPlugin\packages\esp8266\hardware\esp8266\2.4.1\variants\generic" -MMD -MP -MF"sloeber.ino.cpp.d" -MT"sloeber.ino.cpp.o" -D__IN_ECLIPSE__=1 -x c++ "..\sloeber.ino.cpp"  -o  "sloeber.ino.cpp.o"
'"C:\eclipse\arduinoPlugin\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++"' is not recognized as an internal or external command,
operable program or batch file.
subdir.mk:18: recipe for target 'sloeber.ino.cpp.o' failed
make: *** [sloeber.ino.cpp.o] Error 1

12:52:45 Build Failed. 2 errors, 0 warnings. (took 264ms)

Jantje

It looks like there is a install issue.
Does '"C:\eclipse\arduinoPlugin\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-g++" exists on your disk?
If not delete the folder C:\eclipse\arduinoPlugin\packages\esp8266\tools\xtensa-lx106-elf-gcc\ and deinstall and reinstall the esp8266 platform.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

mAzharIqbal

It exists. I removed and reinstalled the plugin with no luck.
I have also downloaded sloeber single file "V4.3.1_win64.2018-10-10_08-21-58.tar.gz". Same issue in it also. (build successful for nano but no luck with any esp8266 board).

I also have Eclipse for eSi-RISC development which I use for another chipset. Could it be messing with sloeber?

01:16:00 **** Build of configuration Release for project test5 ****
"C:\\sloeber\\arduinoPlugin\\tools\\make\\make" all
'Building file: ..\sloeber.ino.cpp'
'make' is not recognized as an internal or external command,
operable program or batch file.
make: *** [sloeber.ino.cpp.o] Error 1
'Starting C++ compile'
make -C "C:\sloeber\/arduinoPlugin/packages/esp8266/hardware/esp8266/2.4.2/tools/sdk/lwip/src" install TOOLS_PATH="C:\sloeber\arduinoPlugin\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2/bin/xtensa-lx106-elf-"
subdir.mk:18: recipe for target 'sloeber.ino.cpp.o' failed

01:16:01 Build Failed. 2 errors, 0 warnings. (took 708ms)

Jantje

You can't build lwip from source unless you have lots of other stuff installed. Doesn't work in windows with Arduino IDE.
Select another option for lwip in project properties->arduino
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -


ov10fac

This may not  be the proper place for this question, if so I appologize.  I have installed sloeber and it is running fine so far.  I run linux and want to built the .desktop file so I can access sloeber from the favorites menue.  Everything is going fine, but I can't fine the sloeber icon.  That is needed to make everything work as its supposed to.  I know there is an icon because when I start sloeber the orange and teal gears show up in my favorites bar (gnome desktop).

Many thanks

Jantje

Have you tried the github repository?
https://github.com/Sloeber/arduino-eclipse-plugin/tree/master/io.sloeber.application/icons
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

ov10fac

Thanks, I never would have found it without that link.  Appreciate the information. 

ageurtse

is it possible to upload a sketch through ota, web or arduino style.
i can't get it to work.

i mannaged to upload, it printes out by serial what the upload ipadres is, but where do i put this in sloeber.

Jantje

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

ageurtse

it sudely poped up in the port selection part.
it took abou 10 minutes to showed up, for now it's working.

Is there a way to set the library version, json library is on sloeber on version 6.x and i need 5.x
how can i change it.

Jantje

>it took abou 10 minutes to showed up, for now it's working.
The whole bonjour stuff no longer works properly in windows 10.

> way to set the library version, json library is on sloeber on version 6.x and i need 5.x
Downgrade to 5.x in the library manager.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Go Up