Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 118665 times) previous topic - next topic

devond

Thread hijacking alert…

Hi Jantje,

I just posted this Q in the Due forum, but see that the man himself (that's you) has this thread going…

Short version, your plug-in rocks but it's not happy when I try to build for the Due as described here:

http://forum.arduino.cc//index.php?topic=195768.0

I'd greatly appreciates any suggestions you may have.  I'll even buy you that Arduino!  ;)

Thank you sir.
-Devon

Dieter-W

Hi Jantje,
the Ardruino Eclipse plugin has problems with Windows 8.1.  MAKE returns with 0xC0000142 (-1073741502 dec).  It's not totally clear to me what's the problem, but it has somehow todo with some changes in DLLs.

Here the problem description:
http://forum.arduino.cc//index.php?topic=194800.0

There is a sollution for the AVR plugin, but I didn't get it to work with the Arduino plugin
http://forum.arduino.cc//index.php?topic=196514.0

regards
   Dieter


Jantje

same post as in the thread you referred

Dieter
Thanks for the early warning. I was not aware windows 8.1 was out. Man; I'm still on xp  8)
The plugin uses the makefile delivered (but not used) by arduino. So the first thing to do is create an issue in github for arduino.
As I do not have a windows 8.1 licence I think it is best that you do this.
As the plugin V2 does not have the path settings anymore as in the avr plugin you can not change the path anymore in V2. In V1 you can but than due is not working.

what I would try:
Install the GNU win 32 project as proposed in the avr workaround you mentioned. http://smallshire.org.uk/sufficientlysmall/?p=689&preview=true
Make a copy of the folder <C:\arduino-1.5.2\hardware\tools\avr\utils\bin> (just to be sure if it fails)
copy <C:\Program Files (x86)\GnuWin32\bin\> into <C:\arduino-1.5.2\hardware\tools\avr\utils\bin> overwriting al files.
try again.

If I understood the problem correctly this should work.

Another thing you could try
Install the GNU win 32 project
add  <C:\Program Files (x86)\GnuWin32\bin\> to your path.
delete make.exe in <C:\arduino-1.5.2\hardware\tools\avr\utils\bin>
You need to delete the file make.exe because the plugin adds <C:\arduino-1.5.2\hardware\tools\avr\utils\bin> to the path in front of the existing path to force to use the Arduino delivered code.

Please feed back whether this helped you out or not.
Best regards
Jantje

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Dieter-W

same post as in: http://forum.arduino.cc//index.php?topic=194800.0

Hi Jantje,
in the meantime I found the problem.  The problem is an old "msys-1.0.dll" in hardware/tools/avr/utils/bin.  Even the 1.5.4 version of msys-1.0.dll is an old version.

I installed MSYS from http://www.mingw.org/ and replaced the msys-1.0.dll in the hardware/tools/avr/utils/bin with the downloaded version.  After the update of the DLL all worked fine.

The problem occurs only when make is called from eclipse, when make is called from a DOS box all works fine.

Jantje, where have I report the problem, so the Arduino 1.5.5 version contains the new msys-1.0.dll ?

Regards
     Dieter

Jantje

Thanks for the feedback
The direct link for a new issue in arduino on github is
https://github.com/arduino/Arduino/issues/new
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Dieter-W

Jantje,
I opened an issue.  Hopefully it is fixed in 1.5.5.

regards
    Dieter

sunsina

Hi Jantje
I followed all of the steps that you have mentioned in http://eclipse.baeyens.it/Install.html
I have setup all the required setting in Windows 7-32bit (Running as a guest machine in VMWareFusion 6.0.2) /Eclipse CDT 32bit Juno/Arduino IDE 1.5.4r2 (installed from executable)/Arduino Eclipse plugin 2.1.0.4 (and test rxtx worked).

I have compiled and programmed a sample Arduino code in Arduino IDE  in the same windows system
and the Arduino IDE programmed my board via microusb (via bootloader) with charm.
It seems the AvrDude and rxtxSerial.dll has no programming issue with my board.


But as soon as I tried to compile and program the sample code in eclipse, I get a problem with avrdude upload.
It seems that it can not put the bootloader on (by sending 1200 bps) or there might be problem with its timing
to enumerate the new USB com port) 

In the eclipse plugin case the avrdude or rxtxSerial.dll cause a severe error that force the eclipse ide to close.

I am wondering what is the problem behind the rxtxSerial.dll or avrdude, while I can program the board  via microusb in Arduino IDE but not in eclipse Arduino plug in?  :~

Anyway thanks for you effort and good luck with developing

Here I have attached a screenshot of the error


Jantje

sunsina
First some questions:
Why do you need  VMWareFusion?
What arduino board do you use?

A remark:
Arduino IDE 1.5.4r2 is not supported with the plugin. You will run in troubles as soon as you try to use libraries.

My thoughts
RXTX is the problem in your case. RXTX will shortly be replaced by something better by the Arduino Core team and the plugin will follow(1). RXTX is known to give problems and I'm not sure how it will behave in a VMWareFusion Session.
I need to know your board as I need to know which code is executed that does RXTX calls.
But from my understanding you would be better of running the eclipse plugin natively (not in a VMWareFusion)

Best regards
Jantje
(1)Note that the Arduino library specification 1.5 which makes  Arduino IDE 1.5.beta and 1.5.4 beta incompatible with the plugin us currently under discussion. The current version can not be supported by the plugin and I hope Arduino IDE 1.5.5 will go back go the previous version. I'm hoping for the best for the new specification. If Arduino persists in a non-supportable library specification I may stop working on the plugin.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Headroom

#354
Nov 13, 2013, 05:51 pm Last Edit: Nov 14, 2013, 12:24 pm by Headroom Reason: 1
To add to Jantje's comments, there is really no reason to use Arduino and Eclipse + Plugin in a VM on the mac.
That combo runs very smoothly natively on a mac. It has been noted that the way the VM assumes the USB ports in some cases
interfers with things.

Here is a link to detailled installation instructions on a mac. http://trippylighting.com/teensy-arduino-ect/arduino-eclipse-plugin/arduino-eclipse-plugin-installation/
http://trippylighting.com

http://ledshield.wordpress.com/

sunsina


In my linux mint-64 environment(running as guest virtual machine) with very same setup I get following error from AVRDude
Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
Please note that I execute  chmod +777 /dev/ttyACM0 in order to make AVRDude program the device.

It does not matter if RTTX is on for resetting or not in eclipse setting.
I am not sure if I have to use udev rules change the name and permission of the device after reset (maybe after the Yun board a new USB device get enumerated like /dev/ttyACM1,...)

Anyway I will give a try to work natively on MAC and check if the plugin works smoothly in that environment or not
Thanks

sunsina

@Jantje
Regarding to @Headroom I followed the setup instruction on (for my MAC machine)
http://trippylighting.com/teensy-arduino-ect/arduino-eclipse-plugin/arduino-eclipse-plugin-installation/
Amazingly the supported Arduino IDE version 1.5.2 does not support Yun board.
I tried leonardeo (the closest configuration to Yun) and I got similar error that I got in my linux environment.
Even upgrading to Arduino 1.5.4r2 compiles the minimum project without showing compilation error but unfortunately
the same error message Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
persist to show in  my MAC and Linux machine (I have tried several different Arduino IDE versions ,eclipse version,.....) None of them
worked  for me.
=(

Headroom

Yes, unfortualately that is the case. It did not occur to me that you were using a Yun until after I posted.

The Yun is supported with the elease of Arduino 1.5.4 but the Arduino team also introduced changes, e.g. how libraries are supported that make it very difficult for third party developers to support the Arduino environment. This does not only concern Eclipse but there are others.

While these third party developers (software as well as hardware). The very well thought out suggestions these third party deveopers have put forth have been met with a surprising reluctance, despite the obcvius shortcomings of the IDE.

Anyway, if you currntly want to use the Arduino Eclips Plugin with an Arduino Yun you are at an impass as the eclipse plugin does not with with the 1.5.4 Arduino environment.

Do you get this message also using the Arduino IDE when runnning on a Mac natively ?
"Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding
Do you get this message "

http://trippylighting.com

http://ledshield.wordpress.com/

Jantje

Headroom explained the situation very well.
I have 2 yun's but postponed my yun projects because of these issues.
If I understood correctly Arduino IDE 1.5.5 will revert to the old library format. Lets hope I understood it correctly.
For the leonardo.
I never got leonardo to work on my Linux (not with Arduino IDE not with the plugin)
It works on windows XP
Apparently it doesn't for for yun on MAC.
The yun bootloader is different from the leonardo bootloader and it is not that obvious with the serial ports popping up and disappearing. It took me a while to get it in my fingers.
Best regards
Jantje
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

steven6282

Hey, sorry if this has been asked somewhere above, but with 24 pages I couldn't find anything and trying to search didn't have much luck.  In the first post it says

Quote

EDIT
version 1.0.10 is now tested on openSUSE
Latest version are tested and running on MAC
Added serial monitor
End EDIT


I'm having trouble finding the serial monitor.  I've looked through all the menus and at all the buttons but don't see anything labeled as or that looks like a serial monitor.

I'm looking for an alternative IDE because for some reason the Arduino IDE will simply not work in WIndows 8 for me.  After a few minutes the GUI stops refreshing itself.  Near as I can tell, it's updating, simply not refreshing.  I can move the window around and when I change the window state in order to force a window redraw operation it updates with anything I've done while it wasn't updating.  Highly annoying and happens with both 1.0.5 and 1.5.4 r2.  I've always liked eclipse in the past for side projects so thought this might be a nice plugin to try out.

Go Up