Go Down

Topic: Windows/Linux/Mac Eclipse plugin to compile and upload arduino sketches (Read 113 times) previous topic - next topic

Jantje


Can you explain me the correct process for adding the utility subfolder to the include path in eclipse?

You need to go into your project properties (right click the project and select properties)
There you can go to this window and add the utility subfolders to the "GNU C" and "GNU C++" languages

Best regards
Jantje

PS note you will see other values. That is perfectly normal.
Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

LuisSoares

Solved.

I had forgot to include the path in the GNU C++. Only included it in the GNU C.

Thank you

Globe

Hi Jantle,

As I explained on this topic http://arduino.cc/forum/index.php/topic,86344.0.html I'm having problems compiling Wire library.

This is the message I get from the compiler console:
Quote
/Applications/Arduino1.app/Contents/Resources/Java/libraries/Wire/utility/twi.c:115: error: conflicting types for 'twi_readFrom'
/Applications/Arduino1.app/Contents/Resources/Java/libraries/Wire/utility/twi.h:45: error: previous declaration of 'twi_readFrom' was here
/Applications/Arduino1.app/Contents/Resources/Java/libraries/Wire/utility/twi.c:192: error: conflicting types for 'twi_writeTo'
/Applications/Arduino1.app/Contents/Resources/Java/libraries/Wire/utility/twi.h:46: error: previous declaration of 'twi_writeTo' was here


Do you have any hint to help me?
Many thanks in advance.

Jantje

Do not PM me a question unless you are prepared to pay for consultancy.
Nederlandse sectie - http://arduino.cc/forum/index.php/board,77.0.html -

Globe

Jantje,

I downloaded "twi.h" from Arduino issue #791 http://code.google.com/p/arduino/issues/list?can=2&q=twi.h&cells=tiles .

I still didn't manage to compile my code and the error is the same I posted above.

Is there any more step to follow? I really enjoy your Eclipse plugin but since I need to compile Wire library, I don't know what to do...

Has anyone else had this problem?

Thanks.

Go Up