Pages: [1]   Go Down
Author Topic: Adxl 345 with SD card... doesn't give any output.  (Read 442 times)
0 Members and 1 Guest are viewing this topic.
UK
Offline Offline
Newbie
*
Karma: 0
Posts: 40
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello guys,

   I am using an Arduino Uno with an accelerometer Adxl345 and a micro sc card with an adafruit adapter. When I run my code  it doesn't give any output. I think the problem is that the pins that the adafruit adapter are the same with Adxl345(11,12 and 13). Does this affect the sensor or the adapter or both?
Logged

The Netherlands
Offline Offline
Edison Member
*
Karma: 50
Posts: 1669
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hi.

You are not telling us what you already did and the results of that, so let's start guessing:

You need to check a few things.
First of all, check what communication mode is to be used.
The ADXL345 supports more than 1 mode.
You should try to use the same mode for both of your devices, and i'd suggest to use I2C (i'm not sure about the SD card supports that).
If you do use I2C, check what address is assigned to your device, each should have its own address.
And you need to check whether termination resistors are in use or not.
There should be termination resistors on 1 device only, prefereble the device that is farthest from your Arduino.

If you don't know the addresses and cannot find them in documentation, you can use Nick Gammon's I2C scanner.
That will tell you the addresses of any device that answeres its "ping".

And if you are mentioning "Your code", post it so someone can have a look at it.
Use the "insert code" button, to be found just on top of the text edit box you type a reply in.
« Last Edit: May 03, 2013, 04:54:08 pm by MAS3 » Logged

Have a look at "blink without delay".
Did you connect the grounds ?
Je kunt hier ook in het Nederlands terecht: http://arduino.cc/forum/index.php/board,77.0.html

Pages: [1]   Go Up
Jump to: