Go Down

Topic: Unbelievable slow compilation of simple sketches (Read 61473 times) previous topic - next topic

oskosk

I was looking for a solution for this problem now in 2015.

I'm on a Windows 7 64bit and dowloaded the Arduino IDE 1.6.0 for Window zip file.

The compilation time was horribly slow (>1minute). And I'm talking about the basic blink example.

I've read about the rxtxSerial.dll replacement solution  but apparently this version 1.6.0 does not ship with that dll file inside.

Solution: Downloaded the windows installer and everything is alright now. Compilation time, less than 10 secs

powerware1974

Hi Everybody

I have experienced same issue with "Arduino IDE 1.6.0 for Window zip" and problem solved when i put Arduino folder in the "Exeption List" of my "Avast free antivirus". After that compilation time changed to normal condition.

fevremartin

I was experiencing the same issue and I found this post. I looked at the responses and this was the answer to the problem.

Make sure the IDE .exe file and particularly all the header files you are using is on a local drive. Also, make sure what ever hard drive it is running from is not bogged down doing a bunch of other things.

The background/foreground preferences should only make significantnt difference if you have a resource intensive process running in the foreground, AND another running in the background. For most people, this setting will nevemakeek noticeableldifferencece and should not be changed from the default.
On my one laptop, I didn't have the libraries on the hard drive but just on a sample flash drive. When I put the libraries in the Arduino > libraries folder, it compiled normally. Thanks!

DrAzzy

While it's taking forever to compile, check task manager process listing. What's using all the CPU time?
ATtiny core for 841+1634+828 and x313/x4/x5/x61/x7/x8 series Board Manager:
http://drazzy.com/package_drazzy.com_index.json
ATtiny breakouts (some assembled), mosfets and awesome prototyping board in my store http://tindie.com/stores/DrAzzy

federicofissore

The IDE writes many files when compiling. Your antivirus may slow everything down because it has to check every single bit that gets written on the harddrive

vaclav

I have "complained " about slow / stop and go / 100% CPU usage when I first switched to Due.
Way back than I received an answer "what do you expect for free stuff ?"
Maybe, just maybe , such attitude is still around, hidden from view.
I still "like" the way software engineers have a tendency to blame their error(s)  on OS.
In  POTS industry we called it "the trouble is leaving here just fine".


Prithul

Hello. The problem is solved. Just uninstall any antivirus or anti malware software from your pc.

CAUTION: uninstalling antivirus software can harm your pc!

InfinityAndBeyond

This is not just an issue for the Windows version but it also has the same slow performance running the IDE on a Mac. There is something fundamentally slow in the IDE coding and not with the Operating System it is running on.

chathurangad

Hi guys,

I was meet up with that problem these days and according to the another thread someone mentioned it was issue with the virus guard. So i tried with turn off the virus guard and try to compile, yes there is huge gap in compilation time with and without virus protection. I'm using AVAST and in it has a feature to enable some places to work without scanning. It helps me. Google about your virus guard and find the way to allow places to work without scanning.

In AVAST Setting>Active Protection>File System Shield>Exclusions add arduino path C:\Program Files (x86)\Arduino\*. It helps me. I think you too.

arduinoobz

Enable AVG = 27s
Disable AVG = 37s
Very slow  >:(

www_jedi

Adding "C:\Program Files\Arduino" to antivirus exclusions solve the problem. Arduino 1.6.8.

varganty

Hi Everybody

I have experienced same issue with "Arduino IDE 1.6.0 for Window zip" and problem solved when i put Arduino folder in the "Exeption List" of my "Avast free antivirus". After that compilation time changed to normal condition.
same problem on Win 10

solution is disable AVAST FREE ANTIVIRUS

Toshibass

I was having same same problem compile took > 3 minutes for small sketch using serial or OTA however I found solution The program that was slowing down compile was IBM's Trusteer .. Rapport which is a fraud prevention program distributed by my bank once I de-installed it, same compile took 10 seconds, now all I need to do is find an alternative or hope IBM produce a fix after I filled in a issue report to them.

jimmystoba

All hail Toshibass!!!! :-)

Praise the lord and hallelujah.

By jove you've done it!

I had the same problem >5mins for an initial compilation then circa 50secs for subsequent unchanged ones. I'm running Win 10 on an intel i5 with SSD.

 After reading the post from the almighty 'Toshibass' above, I remembered I'd installed the 'Trusteer' software sometime ago for a bank account I no longer use.  Removed it and now times are down to <10secs for an initial compile and <5secs for subsequent ones.

ballscrewbob

Slow compiles under Windows

Add the Arduino directories to your antivirus / anti malware / other security exclusions.

So that would be at least two of the following.

C:\Program Files (x86)\Arduino
C:\Users\yourname\AppData\Local\Arduino15      depends on IDE
C:\Users\yourname\AppData\Roaming\Arduino15   depends on IDE

If you have your sketches set up in a different location it's also worth adding that directory to the exclusions also.

Additionally if you also use the online IDE "CREATE" the following directories.

C:\Users\yourname\AppData\Roaming\ArduinoCreateAgent
C:\Users\yourname\AppData\.arduino-create

If you have installed to a different drive swap the drive letter as needed.

If you also have an unzipped IDE installed that path should also be added to exclusions.

Same practices can also be applied to other IDE's, compilation software.
It may not be the answer you were looking for but its the one I am giving based on either experience, educated guess, google or the fact that you gave nothing to go with in the first place so I used my wonky crystal ball.

Go Up