Go Down

Topic: Diamondback combo + airport extreme (Read 1 time) previous topic - next topic

gemo

Bonjour,

Je cherche à faire un simple get sur un serveur web (ex. google pour simplifier ) et afficher la réponse.

Ma config:   wifi diamondback -> base airport extreme  en wpa2 -> modem -> liaison adsl -> .. -> google

J'ai récupéré la doc, les librairies et les exemples que j'ai configuré en suivant les instructions : cela semble bloquer une fois la connection réalisée avec la base, la diode rouge 'wifi' s'allume mais pas de retour.

Quelqu'un a-t il réussi à faire fonctionner un script avec cette configuration ?

Y a t-il un paramétrage à réaliser au niveau de la base airport ?

Merci d'avance

gm

Artouste


Bonjour,

Je cherche à faire un simple get sur un serveur web (ex. google pour simplifier ) et afficher la réponse.

Ma config:   wifi diamondback -> base airport extreme  en wpa2 -> modem -> liaison adsl -> .. -> google

J'ai récupéré la doc, les librairies et les exemples que j'ai configuré en suivant les instructions : cela semble bloquer une fois la connection réalisée avec la base, la diode rouge 'wifi' s'allume mais pas de retour.

Quelqu'un a-t il réussi à faire fonctionner un script avec cette configuration ?

Y a t-il un paramétrage à réaliser au niveau de la base airport ?

Merci d'avance

gm


bonjour
Il semble que cette carte soit une réplique de la blackwidow
http://www.linksprite.com/product/showproduct.php?lang=en&id=74
la librarie linksprite
https://github.com/linksprite/ZG2100BasedWiFiShield
ouvrant sur les exemples "asynclabs"
voir ce forum
http://forum.linksprite.com/viewtopic.php?f=15&t=151&sid=ce8e1a7698faa171a47b84eff72e7bd7
avez vous déjà reussi à vous connecter avec l'exemple webserver ?
voir ce topic ici ouvert récemment
http://arduino.cc/forum/index.php/topic,82080.0.html

et le tuto de skywodd
http://skyduino.wordpress.com/2011/12/10/test-arduino-blackwidow-et-shield-wishield-de-async-labs/

gemo

Merci, pour cette réponse rapide.

Il y a bien un ou deux posts que je n'avais pas vu mais rien de bien déterminant quand à mon problème.

Je vais réinstaller la librairie indiquée et repasser les scripts pour vérifier à tout hasard.

Cdlt

gm

al1fch

Bonjour

Au moins une bonne nouvelle : Aiport Extreme est déclarée 'positive' dans la liste de compatibilité !
http://asynclabs.com/wiki/index.php?title=AP_compatibility_list

L'Airport Extreme est annoncée comme 802.11b/g/n
Est elle actuellement effectivement configurée pour accepter , entre autres, le 802.11b ?

gemo

Bonjour,

Je pense également que c'est le point à vérifier, le fait que la diode wifi reste allumée indique bien qu'il y a une négociation  base/carte.

Par ailleurs, elle n'aboutit pas car l'adresse IP de la carte n'est pas visible par un ping.

La question que je me pose avant de modifier le réseau est de savoir si la base AiportExtreme  est capable de switcher automatiquement entre les différents  modes  (quoique à la réflexion cela signifierait l'absence de garantie quand à la vitesse et la portée du réseau local).

Cdlt

gm


Artouste


Bonjour,

Je pense également que c'est le point à vérifier, le fait que la diode wifi reste allumée indique bien qu'il y a une négociation  base/carte.

Par ailleurs, elle n'aboutit pas car l'adresse IP de la carte n'est pas visible par un ping.

La question que je me pose avant de modifier le réseau est de savoir si la base AiportExtreme  est capable de switcher automatiquement entre les différents  modes  (quoique à la réflexion cela signifierait l'absence de garantie quand à la vitesse et la portée du réseau local).

Cdlt

gm




bonjour
Vous avez sur votre OS de disponible la commande arp -a ? (sous windows : executer -->command-->arp -a
Si vous avez une led fixe wifi c'est qu'une association est réussie.
avec cette commande vous devriez peut être "voir" l'adresse mac que vous avez attribué à votre carte en regard d'une IP.

avez vous  déjà essayé l'exemple très basique fourni ? webserver

schizophrene

Hello!

Pour avoir légèrement galéré pour ma BlackWidow (dont la DiamondBack est clonée), as-tu essayé de changé la configuration du chiffrement dans le programme (j'essayais de me connecter en WPA2, alors que je suis en WPA...)?
As-tu resté en mode INFRA (et non ADHOC, mode dans lequel la led wifi peut s'allumer, sans pouvoir pinger la carte ni faire quoi que ce soit de plus)?

gemo

Bonsoir,

"Hello World!! I am WiShield"

Le sketch serveur web fonctionne enfin .

- j'ai réinstallé la librairie indiquée plus haut.

- dans l'utilitaire Airport menu Airport/Clients sans fil le nombre de clients connectés est indiqué, en cliquant dessus la liste des clients apparait avec un id et le mode : la carte en mode b y figure bien (donc il y a détection automatique du protocole sans avoir besoin de modifier manuellement la configuration de la base)

- dans le menu Airport/Historiques, la log confirme la connexion (et donc bien que la diode Wifi s'allume)

- par contre, et c'est peut-aussi cela qui bloquait,  pour  local_ip[] dans le sketch  il fallait indiquer une adresse  en 10. et non en 192. pour répondre à un ping et être adressée par le navigateur.

Merci à tous pour vos contributions.

Cdlt

gm


Go Up