Go Down

Topic: Compiling problems in Linux. (Read 718 times) previous topic - next topic

Yankee

Dec 14, 2011, 12:44 am Last Edit: Dec 14, 2011, 12:50 am by Yankee Reason: 1
I just did a clean reinstallation of Ubuntu 10.04 and Windows XP. I have no problems with the Arduino IDE on the Windows side but in Linux I get this error (or something similar) with every sketch I try: ""pinmode" was not declared in this scope". This error even appears with the "official" Arduino examples. The same problem occurs no matter which release I try (I've tried every one from 19 to 1.0) I'm very puzzled since it worked prior to the reinstallation. I would be very sad if I had to work in Windows  =(.
PS: I am using a Duemilanove.

mstanley

pinMode is defined in Arduino.h which is located in <installation directory>/arduino/hardware/arduino/cores/arduino.  It looks like your application (Arduino) is not able to locate it.

You may need to set your PATH to include <installation directory>/arduino or you may have to edit the working directory in your program launch icon or in the menu item.

James C4S


I get this error (or something similar) with every sketch I try: ""pinmode" was not declared in this scope"

Sounds like a problem (or something similar.)

(Hint, post the actual error message.  It probably gives you a hint to the path it is trying to WConstants.h or Arduino.h which defines some of that.)
Capacitor Expert By Day, Enginerd by night.  ||  Personal Blog: www.baldengineer.com  || Electronics Tutorials for Beginners:  www.addohms.com

smeezekitty

Does it have any file not found or other errors or is that the only one?
Avoid throwing electronics out as you or someone else might need them for parts or use.
Solid state rectifiers are the only REAL rectifiers.
Resistors for LEDS!

Yankee

There are quite a few errors shown but I can't figure out how to copy and paste the error message here. Mostly what it says is "no such file or directory" for various files so it is obviously not finding them. So how do I set the proper path?

Coding Badly

I can't figure out how to copy and paste the error message here


Drag the mouse through the status window to select.  Press Ctrl+C to copy.  Paste into a reply.  Ctrl+A also works in the status window to select all.

Yankee

For some reason I seem to be able to copy but not paste. I tried "Cont+C", "Copy" from the drop down menu, and "copy for forum". When I did "copy for forum" A message appeared above the status window saying "code formatted for Arduino forum has been copied to the clipboard. But when I try paste in the forum, there seems to be nothing on the clipboard. I'm baffled!  :~

Coding Badly


What about a "print screen"?  Does that work?

(Hint: you can attach files to a post)

Yankee

I just switched to the Windows side and it works fine:

Quote

  if(currentMillis - previousMillis > interval) {



I'll go back and try the "print screen".

Yankee

#9
Dec 16, 2011, 08:51 am Last Edit: Dec 16, 2011, 08:58 am by Yankee Reason: 1
Having trouble with that, too.
Enough for tonight. Need to catch some Zzz's

Go Up