Go Down

Topic: Upload Timeout Error on Mega 2560 - Not Sure What Changed (Read 59 times) previous topic - next topic


I have the same problem.  I have a new Mega R3.  I tried both Arduino 0022 and 1.0 on my Mac OSX 10.6.8.  Sometime my sketch will upload fine, but most of the time it times out.  Doing some Google searches, I found this seems to be a known problem, but I'm not sure how to fix it.  I've seen some talk about avrdude, but I don't know anything about fixing, compiling and uploading a boot loader.  Since this problem seems to be kind of old and my hardware and software are new, I'm surprised this problem still exists.  What should I do?


Moi aussi. But I can upload with Parallels PC emulator running Windows XP on my MAC but not my actual MAC.

Smooberry Dooberry.


Apr 12, 2012, 01:16 pm Last Edit: Apr 12, 2012, 01:41 pm by deajan Reason: 1
Having tested alot with this problem, i found this:

Whenever i have string in my sketch which has threee marksigns in a string (eg: "!!!"), my sketch will make the Mega2560 timeout when uploading ("huh?..bootloader>" hex code message followed after multiple retries by avrdude: stk500v2_ReceiveMessage(): timeout ).
Using Windows 2008 R2 Server (think Win7 64 will do the same), Arduino IDE 1.0 & Arduino Mega2560 compatible.

Here's a sample sketch to reproduce the error:
Code: [Select]

void setup()

void loop()

Hopefully this will help.


Thanks, that solved the problem for me.
I'm running Mac OS X 10.7.3, Arduino IDE 1.0 & Arduino Mega ADK r1.


Thanks to Michael635 for showing that replacing the AVR directory from rev-0023 solves the problem. It solved mine!

Go Up