Pages: [1]   Go Down
Author Topic: Load Cell OpAmp  (Read 1224 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Jr. Member
**
Karma: 0
Posts: 52
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I'm using a 1kg Load Cell which I bought here near our place.
And i use this blog as a reference:
http://cerulean.dk/words/?page_id=42

in the place where I bought the loadcell, they don't have INA125P which is needed. That's why I bought a equivalence IC of this which is INA114P. I research the data sheet of INA125P and INA114P and base from this. I connect the Pin to INA114P. And use the Code:
Code:
void setup()
{
Serial.begin(9600);
}

void loop()
{
int weight = analogRead(0);
Serial.print(weight);
delay(1000);
}

But the problem is. The program only shows two outputs in the serial monitor. And it is if a large amount of weight is applied and when there is no weight or low amount of weight is applied.

Example Output if there is weight applied
Code:
50
51
52
51
50
51
51
51
52

Example Output if there is no weight applied
Code:
152
150
152
151
151
152
152


For your reference here is the connection that i made with my IC and loadcell.
Arduino Analog 0 -> pin 6 IC
Arduino 5v -> pin 7 IC
Loadcell (Red) -> 5V Arduino
Loadcell (Black) -> Gnd Arduino
Loadcell (Green) -> Pin 3 IC
Loadcell (White) -> Pin 2 IC
Resistor -> Pin 1 and 8 IC

Please Help me.And Thanks smiley
Logged

Offline Offline
Newbie
*
Karma: 1
Posts: 48
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Few questions:

What voltage difference are you getting across the load cell at different weights?
What voltage are you reading on your IC output pin at the different weights?

Are you using the DIP packaging or the SOL packaging (different pin outs)?
based on the PIN outs it looks like you are using the 8 pin DIP package, please verify

If you can supply the above questions, we might be able to give you some more specific solutions.

50 ~ 0.24 volts (using a 5 volt reference on the ADC)
150 ~ 0.75 volts
your IC can't pull all the way to ground or Vcc, you want to try swapping the outputs on your load cell to the IC to make the voltage go more positive instead of negative with added weight and check your gain amounts. 
Also it looks like the example blog changed the Vref for the ADC to internal setting Vref to 1.1 volts instead of the default 5V.
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 52
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

https://sites.google.com/site/vitorrosamd/load-cell-arduino-interface
Logged

Pages: [1]   Go Up
Jump to: