Pages: 1 2 [3]   Go Down
Author Topic: problem programming Attiny85 with UNO  (Read 14197 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

So perfect work. Thanks a lot!!!

Now I can finally program the ATtiny85...

Here just a simple sound sensor that activates a relay... working!

Logged

Tilburg, Noord Brabant
Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

That's great!

Over here no succes yet.

Instead of that I get this:
After Burning Bootloader to ATtiny45

This should be ok.
And then it happened:
After trying to upload the sketch to the ATtiny


What went wrong?
Logged

to baldly code what no man has coded before

Global Moderator
Dallas
Offline Offline
Shannon Member
*****
Karma: 207
Posts: 12912
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset


How did you disable auto-reset?

Is the LED on pin 9 fading when the TinyISP sketch is idle?
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I know that the question is not for me, but in my case, I used the 120 Oh resistor, adding two resistors to get that value.

Logged

Tilburg, Noord Brabant
Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have to check pin 9 with a led.

I used a 10 uF from an old VCR so it might be faulty or the legs are too short to use in the bread board. New ones are on their way.

I will put a led on pin 9 and try a resistor.

(I bought a clone Uno so I don't know what bootloader is on the Uno itself)

I'm going to try again, I'm new at this so my stock of resistors is limited but I will try.
Logged

to baldly code what no man has coded before

Offline Offline
Full Member
***
Karma: 0
Posts: 128
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I have to check pin 9 with a led.

I used a 10 uF from an old VCR so it might be faulty or the legs are too short to use in the bread board. New ones are on their way.

I will put a led on pin 9 and try a resistor.

(I bought a clone Uno so I don't know what bootloader is on the Uno itself)

I'm going to try again, I'm new at this so my stock of resistors is limited but I will try.

I have a clone Arduino uno...
Logged

Tilburg, Noord Brabant
Offline Offline
Jr. Member
**
Karma: 0
Posts: 53
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I've made this configuration with a couple of resistors to get exactly 120 ohms.


Now I get this error message after the Rx led on the Uno flashes three times:


This is the orientation of the ATTiny in the bread board wrt it's connections.


(I previously bent the legs of the cap for a better fit in the bread board but no results there)

(I'm going to clear everything today to put an extra lamp on the ceiling tomorrow)

EDIT:

It's working now!!!

I made the rookie mistake of not connecting the ground of the chip after I used the ground lead for the resistors and I left the cap and resistors out and now it works.
So the auto reset is not disabled. I also connected a led to pin 9 to see the heartbeat.

Thanks guys for the support.

Here a short vid of the result.
Brake lights for my Team Associated SC10 short course race truck.
(you cannot see it clear on the vid but the leds burn when the brake is engaged, with the potmeter I can tune the moment of engagement to follow trim of the ESC if necessary)



« Last Edit: December 30, 2011, 01:31:02 pm by mechatron » Logged

to baldly code what no man has coded before

Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset


I have good news, annoying news, and good news.

First the good news.  I've reproduced the problem and I know what is wrong.

Now for the annoying news.  Arduino 1.0 and the ArduinoISP sketch are not compatible.  There are some problems with the ArduinoISP sketch and Arduino 1.0 surfaces at least one of those problems.

And, finally, the good news.  I have an update for the ArduinoISP sketch that works correctly with Arduino 1.0.  If you'd like a copy, send me a Personal Message with your email address.


Please Sent Me.

Thank you.
Logged

Pages: 1 2 [3]   Go Up
Jump to: