Pages: [1]   Go Down
Author Topic: Mega 2650 hangs while sketch uploads  (Read 1013 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I am a teacher and have been tasked with putting together our school's new Makerbot over the holiday break.  I don't have much [any] experience with microcontrollers and am having some issues.

Windows 7 32 bit
mega 2650

I've installed the drivers as per the instructions, and on the device manager the mega shows up w/o a triangle as being connected to com4

When I try to run the blink example, the uploader just hangs and the led by pin 13 blinks five times, pauses, then repeats.  I tried uninstalling and reinstalling the drivers.  There is no firewall up, I've uninstalled "smartboard" software, figuring it may be scanning the ports, I've disabled bluetooth, I've disabled the other com ports on the device manager, I've tried multiple USB cables/ports, I've got the board on bubble wrap to prevent conduction between pins.  Of course I have tried rebooting the computer several times during all of this. 

When the board is connected, com4 pops up as an option on the tools --> serial port menu, it isn't there when the board is disconnected.

The makerbot shield is installed, and I can't get it off.  I've given it a pretty firm tug, but I'm afraid I may do damage to one of the boards if I pull harder.

There is a reset button on the makerbot shield, and I've tried pressing and holding that, but the same thing always happens when I try to upload blink.  Below is the message I get after ~15 minutes of trying to upload a program.

I would appreciate any insights or suggestions.

Thank you,
Adam



avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
Logged

Global Moderator
Offline Offline
Brattain Member
*****
Karma: 474
Posts: 18696
Lua rocks!
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Did it ever work without the shield?

Shields are supposed to be removed, but the pins can get stiff. With a gentle rocking motion you should be able to remove it.

Bluetooth and firewalls are not relevant, communications is via USB.

I would try fairly hard (but carefully) to remove the shield, and see if you can get a basic Blink sketch going.
Logged

Pages: [1]   Go Up
Jump to: