Go Down

Topic: Arduino Powered X10+RFID Controlled Curtain Opener (Read 7 times) previous topic - next topic

bHogan

#25
Oct 19, 2010, 03:22 am Last Edit: Oct 19, 2010, 03:46 am by BroHogan Reason: 1
Yes, to either right of left tip and ground to "barrel". Plug in AUX.
First I tried the scope but couldn't tell much. With the speakers on I could hear when the signal was weak. Later, I put a call to tone() Thomas's example:
Code: [Select]
// Process commands received from X10 compatible RF remote
void processRfCommand(char house, byte unit, byte command, bool isRepeat)
{
 if(!isRepeat)
 {
   tone1.play(2400,1000); // <---- ADDED THIS
   printX10Message(RADIO_FREQ_MSG, house, unit, command, 0, 0, 0);
 }


Then I could walk around and do some fine tuning by seeing how far I could go and still hear the tone.
"Data is not information, information is not knowledge, knowledge is not understanding, understanding is not wisdom."
~ Clifford Stoll

Phil.H

#26
Oct 19, 2010, 07:48 am Last Edit: Oct 19, 2010, 08:31 am by phil.harlow Reason: 1
@BroHogan did you have to modify the code at all to get it to work?
I was able to hear the x10 rf "sounds" over the steady beep beep beep coming from the 315 receiver and tuned that to double or triple the reception distance. (~160* CCW)
I've then got it wired into the arduino like so: http://load-8-1.blogspot.com/2010/06/x10-plc-rf-ir-and-computer-interface.html
and have loaded the X10_test sketch to the arduino.
Problem is, I'm seeing the "X10" startup message over serial, but nothing when firing an x10 rf controller. Adding some logging to the X10rf lib I can see the receive() function is firing 10+ times/sec but not sure what I should try next. @ThomasM any troubleshooting tips/things to check?


Thanks!!

Edit: Nevermind :) I guess the signal was too weak. Adding an antenna it seems to work great!

Edit2: I found that some of my wireless remotes wouldn't work. The mini keychain one worked fine as its signal came out alot faster (I found this out via the audio technique) than the palm pad remote. I adjusted all of the max time values in X10rf.h to 25000, 2200, and 3300 respectively and now it works great! Sweet!!

Thanks for your great work Thomas!

ThomasM

@Phil.H & @BroHogan

Hi glad to hear that you got it working. Do any of you guys have an Arduino Ethernet shield? I just finished v1.0 of my X10_Ethernet sketch ( code published on Google Code). Basically, it lets you control everything through a RESTful webservice using JSON protocol. Web service is protected using HTTP Basic Authentication. I'm publishing an Article explaining how to use the REST & JSON stuff soon.

I also added support for storing module types and names of up to 16 characters in Arduino EEPROM.

I'll start working on an Android app next week, hopefully I'll have something done next weekend. REST & JSON is supported by both the iPhone, Android and .Net frameworks :)

If you download the X10_Ethernet sketch from Google Code, make sure you get the latest version of the X10ex library as well.

@Phil.H

Could you check what the lowest values that work with your remotes are, when setting the max time values? I'll add comments in the code for people using the same remotes you do. BTW: If you set the bit0 max to 2200, you should set the bit1 min to a value higher than 2200. The code reads the bit1 values first, so the bit0 max you are actually using is probably 2099.

-Thomas

Go Up