Go Down

Topic: avrdude: verification error; content mismatch (Read 5058 times) previous topic - next topic


Ok, So I'm a new guy around here, but I've picked up on this Uno pretty quickly. Most recent project has been using the ArduinoISP to program some Atmega8's. So far (with a bit to do) I finally got it to burn the bootloader, and now I'm trying to just load sketches with it.

Oddly enough I couldn't get the bootloader burnt onto the atmega8 with arduino 1.0, I had to use 0023. Which is great since it worked, but for some reason its not uploading sketches in either 1.0 or 0023. I get the same error:

avrdude: verification error, first mismatch at byte 0x0000
         0x3f != 0x00
avrdude: verification error; content mismatch

The odd thing, it'll actually upload the ArduinoISP sketch to the atmega8 (accidentally found out ha ha), but nothing else will upload without that error. Ok I take that back, now I'm not getting anything on the atmega8 with out the error. Any ideas?

Thanks :D



Dec 30, 2011, 02:26 am Last Edit: Dec 30, 2011, 02:42 am by neato3000 Reason: 1
Ok, Well it seems to have fixed itself some how. All I did was closed down all the arduino 1.0 and 0023 ide windows, reopened 0023 and poof it worked. Maybe this'll help some else who is having a similar issue.


ps, spoke to soon... shut down the ide, opened it back up, and am having the same issue again :~

pss, then re-burnt the bootloader with 0023 and now it works?? kinda tricky...


So, after playin around with it, I'f figured out that I have to re-burn the bootloader before I can upload a different sketch than what is on there. Almost like it's not getting rid of what is already on the chip from the last burn and upload. Any ideas?


I haven't done what you're trying to do so this could be way off, but are you sure you're supposed to be loading a bootloader onto the Atmega8? I had got the impression that the technique was to load an ISP sketch onto the host board and then use that to upload your target sketch directly using the ISP - no bootloader needed at the Atmega8.
I only provide help via the forum - please do not contact me for private consultancy.


Yeah, I thought about just loading the sketches, and Had tried that as well. But I'm sure I was doing it wrong. When you say loading the sketch onto the uno, are you talking on top of the arduinoisp? I'm going to try running with out a boot loader on the atmeg8 and see what happens when I get home. I only have one more atmega8 with out a boot loader on it. I'll see how that works out. Was kinda curious how to set the fuses on these things too, any idea?


Dec 31, 2011, 07:29 am Last Edit: Dec 31, 2011, 07:33 am by neato3000 Reason: 1
Okay, So the Atmea8 took the first sketch with out needing to burn the bootloader. Kinda weird because it was the RTTTL sketch from the tones library, and it played twice as slow, which suggested to me it was using the internal clock. At any rate, I tried to burn another sketch, and got the same result, had to burn the bootloader before I could upload a new sketch. I was looking through what the fuses do, and thought about the setting that keeps whats on there after each erase cycle, but I wouldn't even know what fuses are set on these things. How do you get to the command line to use the avrdude in xp?


Bringin this up again since I still have not resolved the issue. I've found I can load the sketch as many times as I want as long as I burn the bootloader first before each sketch. If I don't burn the bootloader first before each sketch, I get the verification error. Any one have any ideas, or can any one point me in the right direction here? Programming the atmega8 using an arduino uno, as well as using arduino 0023 since 1.0 won't work right for programming via the arduino isp. It's gets a little silly to have to burn the bootloader to load a sketch that has only one small change (e.g initial variable value). Thanks Guys!



Was there any solution to this one?

I'm getting the same basic thing on a 328P; I can burn the bootloader and it'll upload a sketch *once*. After that - no dice, I have to re-burn the same bootloader and then upload a sketch. Kinda sucky, since I'm not interested in even having a bootloader on the chip in the first place, but it was the only way it would upload.

I'm pretty sure it's something obvious. I'm just not seeing it.


Found it. Total newb move on my part: I was trying to upload as if it were directly connected, not File->Upload Using Programmer.

I found the hint in a reply post by Riva in this thread: http://arduino.cc/forum/index.php/topic,131456.0.html

As I thought - it was a silly mistake. I'd been burning AT Tiny 85's a few weeks back with no issues, but this one step of the process I forgot!


avrdude: verification error, first mismatch at byte 0x0000
         0x3f != 0x00
avrdude: verification error; content mismatch

I have the same problem (see this post): http://arduino.cc/forum/index.php/topic,132748.msg998878.html#msg998878

Nobody has replied yet.

Strange thing is it only happens after re-flashing the bootloader. I get the error once when trying to upload a sketch, then after that uploads work fine.

I tried three different UNO boards to see if maybe I had a "sick" board, but they all do the same thing.

I wonder if it has anything to do with the 1.0.2 version of the IDE? I never had this problem with 1.0.1.

Gentlemen may prefer Blondes, but Real Men prefer Redheads!


I was trying the upload 'Upload' button to an AT328p on a breadboard via a Leonardo with the ArduinoISP sketch under 1.0.1. But what I should have been doing all along was the File -> Upload using Programmer. That works. The confusion came about because I don't think I needed to do that to AT85's, one for audio and one for an RGB LED (that I just finished doing a while back).

I'm not familiar with using the AVRISP MkII, but I assume you're already doing the correct thing (File->Upload via Programmer), and not by hitting the upload button in the IDE GUI as if you were just uploading a sketch normally, right?

Go Up

Please enter a valid email to subscribe

Confirm your email address

We need to confirm your email address.
To complete the subscription, please click the link in the email we just sent you.

Thank you for subscribing!

via Egeo 16
Torino, 10131