Pages: [1]   Go Down
Author Topic: Error while burning bootloader  (Read 1288 times)
0 Members and 1 Guest are viewing this topic.
Greece
Offline Offline
Newbie
*
Karma: 0
Posts: 18
Your Desire For Success Must Be Greater Than Your Fear Of Failure
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I was palying with the xbee. And the xbee shield jumpers was in the wrong place. After a some times uploading sketchs i got this error.
Done uploading
avrdude: stk500_getsync(): not in sync: resp=0x00

After googling i found out that my avr microcontroler needs to be re-burned.

So i choosed this way ->Minimal Circuit (Eliminating the External Clock)
from here
http://arduino.cc/en/Tutorial/ArduinoToBreadboard

and i got this error
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

Do i have any hopes to fix it?

thanks.
Logged

Your Desire For Success Must Be Greater Than Your Fear Of Failure

United Kingdom
Offline Offline
Tesla Member
***
Karma: 224
Posts: 6614
Hofstadter's Law: It always takes longer than you expect, even when you take into account Hofstadter's Law.
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

You can only burn a bootloader into an atmega processor without a crystal and caps connected if the fuses are still set to use the internal clock.
Logged

Formal verification of safety-critical software, software development, and electronic design and prototyping. See http://www.eschertech.com. Please do not ask for unpaid help via PM, use the forum.

Offline Offline
Newbie
*
Karma: 0
Posts: 7
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hi,
i got following error while burning bootloader
avrdude: stk500_getsync(): not in sync: resp=0xe0

how i can fix it?

thanks
Logged

Pages: [1]   Go Up
Jump to: