Go Down

Topic: issue burning bootloader (Read 2309 times) previous topic - next topic


Jan 06, 2012, 04:24 am Last Edit: Jan 06, 2012, 04:31 am by jfenwick Reason: 1
I tried putting a new Atmega328P-PU chip in my Arduino Duemilanove and burning the Arduino bootloader using Arduino 1.0 on OS X using an AVRISP mkII. It's been 5 minutes and the Arduino program is frozen, and the orange light and the green light are both on on the AVRISP mkII.
Should I just force quit the program?
What could be going on here? How can I diagnose this?

After 10 minutes of sitting there it finally came back and said Error while burning bootloader.

Coding Badly

Should I just force quit the program?

I would have.

What could be going on here? How can I diagnose this?

I vaguely recall that the AVRISP mkII requires a different kernel driver in order for it to work with AVRDUDE / Arduino.

Do you have the processor that was originally in the Duemilanove?  A processor with a working bootloader?


I do have it.

I know I could use the Arduino as a programmer to program the new chip, but I have the ulterior motive of wanting to program AVRs using my AVRISP mkII. I've successfully used it before, but I'm starting to worry I killed it or something.

Coding Badly

Search the forum for other folks who have used a mkII.

Coding Badly

Yup.  Google...


Jan 07, 2012, 01:41 am Last Edit: Jan 07, 2012, 02:06 am by jfenwick Reason: 1
Eh, I looked, none of those links are really helpful, especially because I'm on OS X not Windows.

And I have been searching through forums, lots of forums, here, avrfreaks, pololu, adafruit, sparkfun, sites I've never even heard of before... trust me, I've already spent several days this week digging for more information.
I'm starting to get a bit disenchanted by this search.
You'd think Atmel would provide some sort of help support system for people just starting out.
I think if I had bought a USBtiny I would probably get more support from the adafruit forum than I would have from Atmel :(


You'd think Atmel would provide

For Macs?   Don't be silly!   Atmel has made abundantly clear (with AVRStudio 5) that they only support Windows.

http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1144460244 perhaps?


Jan 10, 2012, 06:59 am Last Edit: Jan 10, 2012, 05:30 pm by jfenwick Reason: 1
So due to totally failing at getting the AVRISP mkII to work, I've switched to trying to burn a bootloader using another Arduino on Arduino 1.0.

I'm following the instructions here: http://arduino.cc/en/Tutorial/ArduinoISP
Also this thread seems helpful: http://arduino.cc/forum/index.php/topic,61776.0.html
I'm using two Duemilanoves.

I have an LED on pin 9 on the programmer board and it pulses on and off slowly when the ArduinoISP is idle.
If I try to program the chip on the other board it says:
avrdude:stk500_getsync(): not in sync: resp=0x15

If I put 4 470 ohm resistors in parallel (to get 117 ohms) and use those to connect 5V and RESET and that didn't help either.

Coding Badly



I don't think that's the problem...

I tried changing the serial buffer as mentioned here:

It doesn't seem to have fixed the problem, except now the resp=0x66 instead of 0x15

Coding Badly

At what point in the process are you applying the 117 ohms resistance?

After trying to burn the bootloader, does the pin 9 LED continue fading?

Go Up