Go Down

Topic: Can't upload to arduino mega 2560 (Read 414 times) previous topic - next topic

I am Running windows 7 32bit
the only com port that shows up is com3
the programmer is set to USBasp

When I click upload the following message comes up-

Binary sketch size: 1526 bytes (of a 258048 byte maximum)
avrdude: stk500v2_command(): unknown status 0xc8
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

If anyone can help me fix this that would be great

avrdude: stk500v2_command(): unknown status 0x01
avrdude: stk500v2_disable(): failed to leave programming mode

sanches2

dude i have the same thing going on here.... so tired of this. I even bought an AVR ISP mkII to change the bootloader , changed the Atmega 8U2 :(
nothing with both environments 0.22 and 1.0 the same.
I run XPsp3 and have perfectly working atmel mcu on the board. I can't believe that i bought one more after this (an arduino Ethernet) and it turned out that the firmware was incompatible to FTDI usb2serial adapter - needed a firmware change.
The reseller from robotev.com (yes it is a genuine arduino) didn't offer me a replacement or fix.
Guys i bought it so to concentrate on application not the HW. I design hardware all day and this thing ruined at least 5 Saturdays of mine and like 45+35+50 Euro :(
I really liked your stuff before i bought it. =(
If it's working - do not touch it...naaah! hack it!

kd7eir

Do you have any shields plugged in while trying to upload?
If so, unplug them while uploading.

Can you unplug the board, go to device manager >, then plug the board back in. Go to Ports (COM & LPT) > Arduino Mega 2560 (COMX), and make sure that it's showing the same COM port that the IDE is showing for the board.

If it is, try changing the COM port to a higher port as follows:

To do this: Close the IDE, go to device manager > Ports (COM & LPT) > Arduino Mega 2560 (COMX) > Right click > Properties > Port Settings > Advanced

There you can force the com port to any other one.  Generally a higher port works best.

Restart the IDE, change the COM port to match the one you set above, and try uploading again.

Go Up