Pages: [1] 2   Go Down
Author Topic: avrdude:stk500_getsync():not in sync: resp=0x00  (Read 1957 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ciao a tutti! sto provando qualche codice, quando carico il programma mi dice ''done uploading'' ''bynary sketch size...'' e sotto mi viene fuori ''avrdude:stk500_getsync():not in sync: resp=0x00''
cosa vuol dire?
grazie!
luca
Logged

Global Moderator
Milano, Italy
Offline Offline
Edison Member
*****
Karma: 19
Posts: 1175
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

hai selezionato la board giusta?
Logged

F

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 325
Posts: 22498
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ma mettere qualche dettaglio in più?
Tipo la versione dell'IDE, la scheda che usi, il SO, ecc....
Logged


Rome
Offline Offline
Full Member
***
Karma: 2
Posts: 186
I love Arduino
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Prova a selezionare la scheda corretta sull'IDE.
Tools --> Boards

Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

hai ragione scusami. allora uso arduino uno con windows 7 x64. adesso ho notato che mi da questo messaggio quando tento di caricare il programma e ho la shield motor montata. la board è quella giusta anche perchè senza shield carica perfettamente!
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 325
Posts: 22498
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Se la shield impiega i pin 0 e 1, che sono quelli per la trasmissione seriale, allora la shield interferisce sull'invio dello sketch.
Logged


Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

non credo vengano usati i pin 0 e 1...
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 325
Posts: 22498
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Che shield è? Puoi mettere un link?
Logged


Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

http://store.arduino.cc/eu/index.php?main_page=product_info&cPath=11&products_id=204

è quella per il controllo dei motori e servi...
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 325
Posts: 22498
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ho visto. Non li usa. Non so il motivo, allora. Bisognerebbe sentire qualcun altro che ce l'ha.
Logged


Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ok grazie! ma comunque solitamente quando si usa una shield non bisogna staccarla tutte le vole che si carica lo sketch giusto?
Logged

Global Moderator
Italy
Offline Offline
Brattain Member
*****
Karma: 325
Posts: 22498
Logic is my way
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Dipende. Alle volte interferisce, soprattutto se la shield usa i pin che ti ho detto, che sono quelli per la comunicazione seriale.
Logged


Global Moderator
Milano, Italy
Offline Offline
Edison Member
*****
Karma: 19
Posts: 1175
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ciao, normalmente non è necessario staccare lo shield quando programmi l'Arduino, a patto che non usi i pin della comunicazione seriale (0 e 1). Quindi dovresti poter lasciar collegata la motor shield.

Ispeziona bene i pin 0 e 1 perchè su quello shield sono passanti, ovvero non ci sono piste collegate, quindi non devono far contatto con niente: nè tra di loro e nè col GND che è tutto intorno.
Logged

F

Offline Offline
Full Member
***
Karma: 0
Posts: 131
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

ho controllato e non sono collegate. oltre tutto mi diventa complicato, io dovrei fare un braccio robot e arduino con la shield sono all'interno di una scatola, mi piaceva far uscire solo la porta usb ma se poi non riesco a caricare lo shetck senza staccare la shield diventa problematica la cosa; dovrei ogni volta smontare e rimontare tutto! devo assolutamente trovare una soluzione!!!
Logged

Global Moderator
Milano, Italy
Offline Offline
Edison Member
*****
Karma: 19
Posts: 1175
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

prova a piegare quei piedini e non farli entrare negli header della scheda Arduino. Vedi se risolvi, altrimenti non è lì il problema.
Logged

F

Pages: [1] 2   Go Up
Jump to: