Go Down

Topic: Kurze Vorstellung und natürlich gleich ne Frage (Read 617 times) previous topic - next topic

Gandalf

Servus
mein Name ist Helmut (48 Jahre), Datenbank- und Softwareentwickler. Ich habe mir vor kurzem ein Arduino Mega gekauft und plane damit die Beleuchtung meiner Modellbahn zu steuern.
Umsetzten möchte ich dies durch teilweise fest programmierte C-Routinen im Arduino und einige über seriell angegesteuerte (über Visual Studio) Beleuchtungseffekte.
Die üblichen Test mit LED 13 usw funktionieren wunderbar, sowohl fest programmiert als auch über serielle Ansteuerung.

Nur....
Ich würde gerne die Pins 21 - 53 als DIGITAL Out testen, und das krieg ich nicht auf die Reihe:
Code:

void setup() {
  pinMode(13, OUTPUT);
  pinMode(21, OUTPUT);
  pinMode(22, OUTPUT);
  pinMode(23, OUTPUT);
}

void loop()
{
  digitalWrite(13, HIGH);
  digitalWrite(21, HIGH);
  digitalWrite(22, HIGH);
  digitalWrite(23, HIGH);
}

Kann mir einer von euch mal die Augenklappen abnehmen und mir weiterhelfen?

Besten Dank

Helmut

mkl0815

Was genau geht denn nicht? Vom Sketch sieht es doch erstmal sauber aus. Hängt an den Pins denn etwas dran, eine LED z.B.?
Grüße,
Mario.

Gandalf

Hallo

an den Pins 21 - 23 hängen drei LED´s, deren Kathoden sind über Vorwiderstand auf GRND geschaltet.
Gleiche Schaltung mit PIN 13 ist ok.
GRND beziehe ich vom 2pol. Pfostenstecker( Pin 21 - 53).

Helmut

MIST !!!

das Experimentierboard ist anders aufgelegt als mein altes........
Sorry, hätte doch vorher messen sollen....

Danke

Helmut

uwefed

Siehst Du, Helmut, Du hast uns geschrieben und schon war das Problem gelöst.   ;) ;) ;) ;)
Grüße Uwe

Go Up