Go Down

Topic: Mega 2560 with Ethernet shield (Read 1 time) previous topic - next topic

streamcyper

No I have not tried any other Ethernet programs on it as it is brand new.
when I try to run the test program I just get connection fail. so it's obvious I'm doing something wrong... 

zoomkat

Quote
I'm doing something wrong... 


Yes, the biggest thing you are doing wrong if you want help is not supplying the requested info on your network hardware and connections.
Consider the daffodil. And while you're doing that, I'll be over here, looking through your stuff.   8)

streamcyper

sorry about that.... I got the the arduino connected to my computer with normal USB cable, and also it's connected to a network switch. my computer is also connected to the switch by cable,  that's all that is connected to the switch. I don't need to be able to connect to the arduino through Internet only through LAN.

the switch I use is this one:
http://us.zyxel.com/Products/details.aspx?PC1IndexFlag=20040520161143&CategoryGroupNo=5BAD15B7-2A64-43F2-9C39-8C5C912AE745


I'm using the arduino 1.0 programming software, it's set up like this:
Board: Arduino Mega 2560 or Mega ADK
Serial Port: COM 4
Programmer: AVRISP mkII

Bajdi

Have you tried the sketch that zoomkat posted? What does the serial monitor say? Have you tried pinging the ethernet shield from your computer? Is the IP that you used in the sketch in the same range as your computer?

streamcyper

when I use sketch Zoomkat gave me, (just copy, paste and change mac and IP) and I get connection failed, Disconnecting.

I use IP: 169.254.216.120 for my PC, and IP: 169.254.216.121 for arduino.

When I try to ping the IP address of my arduino it responds.

Go Up