Go Down

Topic: Serial port already in use- help! (Read 1 time) previous topic - next topic

zanaobscura

Hi,
I am trying to get started with the Arduino Uno on my Mac OS X Lion Version 10.7.2 by testing it with the 'blink' example, as instructed. However, when I attempt to upload the example I repeatedly get the message 'Serial port '/dev/tty.usbmodemmfd121' already in use. Try quitting programs that may be using it'.
I have rebooted and read the troubleshooting guide plus a number of forums relating to this and tried to implement their advice but to no avail. Many forums advise to delete rxtx.jar files and the like from your Java Extensions folder, however, running a search in my finder turns up neither of these.
Any help would be greatly appreciated, as I have all the more complex hardware in place for my project, but am sadly stuck at this basic hurdle!
Thankyou :)
Zana

zanaobscura

Update- after many hours I have worked it out!
It seems there was a problem with a lack of compatability between the Arduino Uno and my USB Driver. I simply upgraded to the latest Mac OS X USB serial driver at FTDIchip.com.
For future users with this problem, the instructions and links I found on this site:

http://geekscape.posterous.com/mac-os-x-17-lion-upgrading-ftdi-usb-serial-dr



Go Up