Go Down

Topic: Montaje CNC, calibrar ejes configuración y software (Read 194 times) previous topic - next topic

grafisoft

Bueno, ya he comprao la perfileria y los accesorios para unirla. Al final la altura del perfil en el que ira el eje X, sera de 30cm, espero no haberme quedao corto. 10cm mas alto que mi actual chasis de madera. El perfil es el de 40 y el total han sido 72e envio incluido en motedis. A la espera estoy de recibirlo a finales de semana o principio de la que viene. He calculado que aproximadamente me saldra un area util de fresado de unos 30x35cm.

Estoy tambien pensando en como hacer la base de fresado, si hacer la pieza en aluminio de 10 o 15mm de espesor, para posteriormente hacer una matriz de taladros y roscarlos con un macho, o ponerla de madera de 16mm de espesor para rectificarla y si sufre daños pues que no me suponga mucho el cambio (tambien si sufre dañs mejor para las fresas que sea madera al aluminio, ya que siempre uso fresas de pequeño diametro).

Nuevamente, el eje Z lo pensare mas adelante aunque tengo los rodamientos lineales ya en casa. Seguramente lo haga todo en aluminio de 10mm de espesor minimo.

@Fm: Aun tardare un poco en pedirte la electronica, quiero dejar el chasis acabado antes, pero esos drivers de 1/32 tendran mi nombre en un futuro ^^

Saludos

Terraguea

#856
Apr 16, 2013, 01:59 pm Last Edit: Apr 16, 2013, 04:10 pm by Terraguea Reason: 1

@Terraguea: Una consulta, que altura tienes en el chasis? (la altura del chasis de la maquina).




La medidas finales del chasis de aluminio son:
470 mm de ancho, 400 de alto y 400 de fondo, el alto es sin contar los tacos de goma que hacen de apoyo y dejan un hueco por debajo para poder limpiar.
Encima de la base de dm chapado en madera he colocado otro dm con tratamiento autoclave ( hidrófugo ) que me hará las funciones de base mártir, así si me paso fresando no daño ni la base buena ni sufrirán las fresas o brocas.

@fm, el fichero gcode de batman no chuta, arranca desde el punto 0,0,0 hasta su primer desplazamiento y allí se queda clavado, al tocar los motores noto un pulso de movimiento pero decimal,así que ha todos los efectos "no chuta".
Dime si lo has probado y así descartar que sea algo de la electrónica o SW, de cualquier forma he probado con otro y funciona todo bien.
Un saludo

grafisoft

Ok, gracias Terraguea. Por cierto, cuantas CNCs llevas ya? lo menos sera 7 :p

fm

Hola Terraguea, si el fichero lo he probado con mi última versión y juraría que funciona. Lo probare otra vez. Lo he ejecutado con repetier. A ver si va a ser un problema con la aplicación que transmite el gcode a la electrónica.

Lo miro a ver ...
   

fm

OK Terraguea, ya se cual es el problema, a que usas Txapuzas CNC Tx?
El caso es el siguiente: el primer comando es una interpolación circular con velocidad. El comando es relativamente largo. Lo que he descubierto es que el programa de txapuzas lo trunca y le esta llegando una orden a la máquina para que tenga un feedrate de F1 o F10. Si esperas lo suficiente veras que se mueve, eso si a una velocidad de 0.1mm o 1mm por minuto!!

Mira a ver si puedes usar printrun, replicatorG o repetier.
   

grafisoft

Madre mia lo que da de si ese fallo del soft :p

fm

Si, creo que alguien más se lo ha encontrado...
   

grafisoft

Si, yo mismo, creo que te volvi loco un par de dias con el dichoso fallo -.-

fm


Si, yo mismo, creo que te volvi loco un par de dias con el dichoso fallo -.-

;)  :*  :smiley-red:

Efectivamente! De todas formas, esa investigación sirvió para mejorar el algoritmo de velocidad y dejarlo mucho más afinado.
   

Terraguea

Wuenas, efectivamente, uso exclusivamente el software de Txapuzas CNC.
He intentado instalar repetier alguna vez, tanto para linux como para windows pero no acaba de arrancar.
De todas formas pensaba que sería más compatible todo esto de los ficheros Gcode y más a resultas de ser creados todos por el inkscape, bien es cierto que otros también me han hecho cosas extrañas.
Por cierto, he intentado instalar el nuevo SW 1.0.0.9 y me dice que "nanai", has añadido la necesidad de alguna librería nueva???, ya que no compila.
Un saludo

fm

Simplemente configura el fichero de configMe.h. Por defecto esta sin MMI ni control térmico y añade una librería de fastIO que ya la tienes en tu sistema. Activa el MMI y control térmico.

El gcode es estandard pero el programa de Txapuzas corta el comando antes de enviarlo.
   

grafisoft

No se puede revisar el soft de txapu y ver donde corta los comandos tan largos??

fm

Si, pero yo no tengo mucho tiempo. Debe ser cuestión de dimensionar algún buffer y aumentarle el tamaño.
   

fm

Hola a todos aquí os dejo la última creación de la T2 que no ha quedado nada mal.
La máquina y la versión del SW se han portado muy, pero que muy bien.

   

Terraguea

#869
Apr 21, 2013, 11:29 am Last Edit: Apr 21, 2013, 11:31 am by Terraguea Reason: 1
Wuenas, el mérito debe de ser el tamaño del fresado, a veces pongo alguna pieza como referencia de escala, una resistencia smd o una moneda para hacerte una idea de la escala, por el detalle de la fotografía parece bastante pequeño.
A seguir ceneceando¡¡¡¡
Por cierto, en la esquina superior izquierda veo una virutilla de madera, límpiala para que Grafi no te llame guarro¡¡¡¡ :P
UN saludo

Go Up