Go Down

Topic: Montaje CNC, calibrar ejes configuración y software (Read 203955 times) previous topic - next topic

copachino

he encontrado un perfil de aluminio que puede que me sirva es un perfil cuadrado de 1 3/4 de pulgada, y 1/8 de espesor de pared, pero no se bien...

esta es la imagen que tome, a lo mejor alguien me dice si pueden servir para el chasis


Terraguea


he encontrado un perfil de aluminio que puede que me sirva es un perfil cuadrado de 1 3/4 de pulgada, y 1/8 de espesor de pared, pero no se bien...

esta es la imagen que tome, a lo mejor alguien me dice si pueden servir para el chasis



A ver, si te fijas en los chasis de aluminio la clave no es tanto las dimensiones del perfil, que son importantes, pero mucho más es su mecanizado y ensamblaje, dicho de otra manera como unir las piezas entre si de una manera segura y que quede algo estético, para eso están los tensores de unión, unen a 90 grados o diferentes grados los aluminios entre si, los hay especiales que pueden ser de más grados, pero lo estandard es 90º.
Esos perfiles que fotografías son tubos cuadrados (de 40x40 o 50x50mm, por lo que se puede apreciar, o algo intermedio), la pregunta es ¿como vas ha montar la estructura entre si? por eso los perfiles de aluminio para estructura de montaje tiene aletas, para poder unir entre si los aluminios, es donde abraza los tensores con un tornillo cónico.
Me cuesta creer que no haya por donde vivas centros de reciclaje de metales donde puedas comprar algún resto de oficina de donde poder sacar los 3-4 m lineales para poder montar un chasis.
Pregunta por aluminio dedicado a montaje de mampara de oficina, o biombos de separación, seguro que encuntras algo mucho mejor que esos tubos y más barato.
Un saludo.

copachino

Sinceramente, es todo lo que he podido encontrar, aun asi, lo que dices es cierto aunque creo que por la estructura que creare no importa si tienen aletas o son lisos, ya que los montare traslapados, ya que mi idea no es una mesa plana como las normales ya que abajo de la mesa ira un pequeño deposito de taladrina que sera impulsado por una pequeña bomba y sera recolectado abajo de la misma mesa... ya tengo los patines montados, mas tarde mandare una foto que te hagas la idea de como es que los quiero montar

grafisoft

Aqui no te puedo aportar nada, mas que remarcar lo que menciona Terraguea, son perfiles con aletas para un facil ensamblaje. En los que pones tienes que estar con taladros y demas

Saludos

Animbius

Hola a todos, despues de un tiempito! mis vacaciones me fueron muy productivas en cuanto a mi CNC. Ya esta funcionando y bastante mejor de lo que esperaba!

Ahora estoy usandola para cortar algunas piezas para aeromodelismo en madera balsa y es casi como cortar manteca con un cuchillo caliente!

Pero tengo dos dudas para exponer, sobre todo a @fm o a cualquiera que pueda ayudarme. (en comentario siguiente!)

Aunque primero quiero tratar de aportar un minimo granito de arena al foro con algo que creo saber:

-Preguntaron no mucho mas arriba si se podia usar una fuente de pc para alimentar con 24V. La respuesta seria "NI" jaja, por lo siguiente: los 12v de tension que entrega la fuente de pc es entre el cable amarillo y el negro (esos colores es lo mas comun al menos), el negro siendo la masa. Lo importante es saber que todos los cables de un mismo color vienen desde un mismo punto, es decir que todos los cables amarillos son en efecto un unico cable (unidos todos entre si en la base). Y la corriente que entregan es por consiguiente la suma de cada uno, no pudiendo superar los valores especificados en su etiqueta.

-Para obtener 24v desde una fuente de pc, se tiene que usar el cable amarillo y el de -12v en lugar del negro. Para asi tener una DIFERENCIA de TENSION de 24v. Sin embargo me temo que para nuestra aplicacion esto no sirve de mucho, ya que la corriente entregable por la fuente en esta configuracion, se reduce drasticamente, ya que el conductor de -12v no suele superar los 0,5A. Todos esos valores estan en la etiqueta de la fuente y siempre hay que valerse por el menor de los valores que estemos por usar.

No quiero extenderme en ese tema ya que hay hilos enteros dedicados.


Animbius

Ahora si, mis dudas!!!!

mas de una vez tuve dos imprevistos con la cnc, que no pude identificar la solucion o el origen del problema.

-El primero de ellos se trata de una bajada de velocidad de avance muuuuy exajerada en alguno de los tramos del Gcode mientras lo ejecutaba en el texapuCNC. El Gcode no tiene el error, ya que es una pieza de la que hice unas 10 copias, repitiendolo sin modificar nada en el procedimiento.
El sintoma en concreto es que a mitad del proceso, en alguna orden los motores se ralentan casi a un paso (micro paso para colmo jaja) por segundo aproximadamente. Lo cual no me daña la pieza pero de un tiempo estimado de 15 min de maquinado puede extenderse a varias horas, lo cual es muy alterante!

-El segundo problema que tuve reiteradas veces, es al conectar y encender la cnc. En ocaciones el eje Z no responde con coherencia a las indicaciones manuales desde la botonera del texapuzasCNC y el motor hace un ruido bastante mas fuerte del normal. No sabria decir si la alimentacion de las fases del motor se alteran o que, pero la cuestion es que la solucion siempre vino magicamente luego de apagar, desconectar, reconectar, encender y abrir software y no en el primer intento sino luego de dos o tres. En dicho proceso reviso siempre todas las conecciones y no encontrando nada extraño, hasta que de repente y como por cuestion de humor, la cnc se digna a responder con serenidad!

En este segundo me inclino a pensar en algo del soft o la electronica ya que los cables de los motores los revice y los motores provados independientemente tambien funcionan perfecto. Por esto mismo es que recurro a ustedes y sobre todo al gran experto en la materia @fm !!! por favor si me dan una mano, ya que la maquina puedo usarla pero es imposible predecir en que momento me traera complicaciones!

UN SALUDO ENORME A TODOS DESDE ARGENTINA!!! 

grafisoft

Respecto a los 24v, realmente no se necesitan 24v. Los motores funcionan a menos y se usan tensiones mayores pero cuidado !la corriente tiene que estar limitada! Usamos una tension superior para poder trabajar a unas velocidades elevadas y que no haya perdida de pasos.

Saludos

fm

#742
Jan 30, 2013, 08:39 pm Last Edit: Jan 30, 2013, 10:13 pm by fm Reason: 1
Una pregunta para ir viendo la configuración:
- que electrónica tienes como CNC (arduino+tipo de driver)
- que SW esta corriendo en la controladora de la CNC (el SW de control es el TxapuzasCNC Rx)?

Un saludo
   

fm

#743
Jan 30, 2013, 08:46 pm Last Edit: Jan 30, 2013, 10:41 pm by fm Reason: 1
Con respecto a los 24V, efectivamente, con una tensión mayor, lo que conseguiremos es que las bobinas se "carguen" más rápido. Normalmente, los motores NEMA 21 estas especificados para trabajar a 3.2V aprox. Como es esto posible? Porque se asume que cuando se satura la bobina, esta se comporta como una resistencia y por lo tanto deja pasar una corriente que es la tensión dividido por el voltaje. Estoy en un móvil y es un poco rollo de contar, pero el efecto que se consigue es poder cargar la bobina más rápido pero hay que controlar la corriente que circula por ella para no quemar el motor.
   

Animbius

@fm , la electronica es la ELFDRV2 completo tal cual como me los enviaste, todavia ni incursione en cambiar la configuracion de la corriente de los drivers. Los motores son nema 23 de la misma marca y modelo que los que publicó Terraguea (jeje un plagio completo lo mio!).

El soft: TexapuCNC_TX03, desde Linux. El RX es el descargado de tu web, con M8 y el resto de las configuraciones sin alterar.


La secuencia de encendido que realizo es la siguiente (tal vez influya en algo sobre la electronica)

1-Enciendo la pc.
2-Conecto el Vinciduino al usb y espero a que los led se estabilicen.
3-Abro TexapuzasCNC_TX, abre sin problemas y reconoce a todo.
4-Conecto la fuente de alimentacion, la enciendo y luego hago de forma manual algunos movimientos desde la botonera del Texapu para ver si responde correctamente.

en ese punto es donde de forma aleatoria el eje Z responde o no. Si responde de una luego no falla en todo el dia, pero si responde mal la unica forma que encontre de corregirlo es apagando todo y repitiendo los pasos anteriores varias veces hasta que se digna a corregirse. (eso respecto al problema numero 1)

Por favor diganme si son claras mis exposiciones, ya que sino se hara imposible tratar el tema jajaja un abrazo!

fm

Hola perfecto.

Vamos a ir por partes para ver dónde puede estar el problema.
Cuando te quedes sin poder mover el eje Z, o cualquier de los ejes, simplemente cierra la aplicación de control y abre el IDE de Arduino. Dentro del IDE de Arduino, abre la consola y en la parte superior le puedes escribir g-codes directamente por ejemplo:
- G01 Z10
y si se mueve el eje Z el código que corre en la vinci va bien. Si no, pues tengo una pulga en el código que tendré que revisar ;) Si el eje se mueve es posible que haya algo raro en el SW de control en Linux.

Yo he probado con printrun / proterface y replicatorG sin ningún problema y funciona muy bien.

Con respecto a la velocidad, eso puede ser debido a varias cosas:
- que en el código G se esté cambiando el parámetro de velocidad
- que tenga una pulga en el código a la hora de hacer los cálculos de velocidad y las cosas vayan más lentas. Miraré el código a ver si veo algo raro.
   

Terraguea

@Animbius, mi secuencia de encendido es muy similar al tuyo pero no igual, me explico:
Después de encender el pc y de trastear con Inkscape que pieza voy a cenecear abro txapuCNC, como todavía no he encendido la vinciduino o conectado al pc a través del puerto USB no puedo activar nada de nada , como mucho abrir el fichero Gcode que quiero cenecear, a continuación conecto la vinciduino y dejo pasar unos segundos hasta que queda a la espera, acto seguido enciendo la fuente de alimentación de los motores ( 12v).
Como he encendido la vinciduino después de txapuCNC no tiene activado el puerto , para comprobarlo pulsa una acción en movimiento y verás que el software te lo dice, así que selecciono su puerto correspondiente y a funcionar a la primera, nunca me ha fallado.

Lo que si he visto es que trabajando con acciones manuales, sin ejecutar el gcode es que a veces "se le va la olla" a la CNC, y siempre trabajando en vacío , me explico:
Cuando necesito desplazar la fresa en vacío hasta la posición 0,0,0 y casi siempre utilizando los ejes X y Y se desplaza mucho más de la orden ejecutada, si la orden de desplazamiento es 10mm a veces se desplaza 130mm, lo cual es un problema si está el eje Z muy próximo a los extremos, así que tengo que estar muy atento y fijarme que si el eje no se mueve estrictamente lo que yo le he mandado prepararme para parar la fuente de alimentación manualmente antes de que llegue a chocar con los extremos del eje ( recordad que carecemos de final de carrera, al menos yo ).
De todas maneras esto no me preocupa lo más mínimo, ya que sucede muy escasamente y sólo cuando muevo el eje para posicionarlo y es cuando más concentrado estoy.
Un saludo

grafisoft

A mi me pasa eso que comentas Terraguea cuando por algun motivo, se queda un ultimo comando en la vinciduino con unas coordenadas X Y Z las que sean y al mandarle uno nuevo se le va la pinza y se pasa. Creo que es debido a que en la electronica le queda una posicion y en el programa del Pc te sale como que estas en 0,0,0 y no es realmente asi. Hay que hacer "home" de vez en cuando. Yo se lo marco cada vez que hago un cambio de herramienta, pues posiciono de forma manual (muevo el eje a mano) el eje Z y asi ya me queda todo bien antes de empezar el proceso.

grafisoft

A ver si llego a tiempo, para Terraguea:

http://frs-cnc.com/es/tienda-mainmenu-47/ferreteria/accesorios.html?page=shop.product_details&flypage=flypage-ask.tpl&product_id=96&category_id=17

Saludos

Terraguea


A ver si llego a tiempo, para Terraguea:

http://frs-cnc.com/es/tienda-mainmenu-47/ferreteria/accesorios.html?page=shop.product_details&flypage=flypage-ask.tpl&product_id=96&category_id=17

Saludos


Pues no, no llega a tiempo, ya me fabriqué uno, lo tengo en el taller preparado para cuando consiga la fresadora, gracias de todas formas.
En este sitio los hay más baratos, adjunto la URL porque tiene cosas muy bien de precio.

http://damencnc.com/es/herramientas/kress/kress-fresadora

Un saludo y gracias de nuevo.

Go Up