Pages: 1 ... 71 72 [73] 74 75 ... 78   Go Down
Author Topic: Montaje CNC, calibrar ejes configuración y software  (Read 179178 times)
0 Members and 2 Guests are viewing this topic.
Málaga, Spain
Offline Offline
Edison Member
*
Karma: 41
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Ningún problema, te van a funcionar bien.
Logged

   

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Muchisimas gracias por la rapidez
Logged

España
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

             Hola, por fin he conseguido que funciones mi eje Z, pero las pruebas que realizo son un poco extrañas porque realiza las figuras, (trazadas con lápiz) como si estuviesen realizadas con un espejo. Es decir para verlo correcto tienes que reflejar en un espejo. Además los círculos no los redondea del todo en fin. Creo que tengo un problema de polaridad de las bobinas ¿no?.

              ngc1300, me descargue la primera versión de tu programa y el fw de fm y con el he conseguido el movimiento con los cursores pero después no ejecutar un gcode. Este finde intentare descargar esta nueva versión y volver a probarlo.
         Por cierto probé ha subirle el voltaje tal como me dijiste en tu anterior post y los motores no funcionaban bien, se quedaban como agarrotados.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Seguramente se quedaban agarrotados por que les entrara demasiada corriente, si subes el voltaje y no controlas la corriente, la corriente que le entra al motor es muy alta, no se exactamente como son esos drivers chinos, pero no creo que tengan regulador de corriente con lo que te esta pasando eso. Yo cuando usaba los l298 fabricados por mi me pasaba eso, no tenia el regulador de corriente. Lo de que salga como en un espejo es porque algún eje esta al revés.

En cuanto al programa, no has podido ejecutar un gcode? Con que programa lo has creado?, en principio yo he probado los mismos gcode que usaba con el programa de txapuzas y me funcionan correctamente, de todas formas pásame el gcode y lo pruebo a ver.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

he puesto una nueva versión del programa con la que se puede usar un gamepad o joystick para manejar los ejes.

https://bitbucket.org/jadiazg/cnccontrol/downloads

Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas de nuevo FM

Este finde he realizado pruebas con los motores y tu drivers, pero se movían como a saltos y uno se me tostó, des pues de darle tropeciantas vueltas vi que el regulador de la corriente (el tonillito) tenia la chapita hacia la derecha del todo.

Otra cosa que he detectado es que cuando se mueve un motor a veces repercute en el resto, incluso se escucha un pequeño zumbido.

Alguna posible solución a esto, eso si aparte de volver a pillar un driver, jeje
Logged

España
Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola de nuevo, he intentado probar tu programa ngc1300, pero debo de tener algun proble en mi pc. estavez no he conseguido car ni el firmware y si tu programa. Pero vamos que mas tarde otemprano lo conseguiere, soy un poco ¡cabezón!
El funcionamiento de mi CNC aceptable... Tenías razón, el eje X estava cambiado por el Y y claro no funcionaba bien. no obstante adjunto foto de dos de los gcode que viene con Txapuzas para ver si me podeis decir que esta pasando ahora con la CNC.

Por cierto ngc1300, con tu programa la primera vez que lo intente fue con el gcode de Txapuzas. Todavia me queda mucho para poder hacer los mios y cuando los realice seran con Inskape, parece el mas facil no¡


Gracias por tu ayuda. Cuando consiga que esto funcione mas o menos me planteare los drivers de fm o los de esteca 55 no ya os pedire consejo.


* P9247926.JPG (1003.7 KB, 2560x1920 - viewed 63 times.)
Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 41
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas de nuevo FM

Este finde he realizado pruebas con los motores y tu drivers, pero se movían como a saltos y uno se me tostó, des pues de darle tropeciantas vueltas vi que el regulador de la corriente (el tonillito) tenia la chapita hacia la derecha del todo.

Otra cosa que he detectado es que cuando se mueve un motor a veces repercute en el resto, incluso se escucha un pequeño zumbido.

Alguna posible solución a esto, eso si aparte de volver a pillar un driver, jeje
El zumbido que escuchas es de la corriente recirculando por las bobinas de los motores. Es algo que no lo hacen los lineales (basados en el ULN) porque no hacen ningún control de corriente activo. Ese zumbido debe desaparecer en el momento que pones el pin de ENABLE a HIGH.

Porque suenan los motores cuando solo mueves uno, basicamente porque aunque no se estén moviendo, si que están trabajando para mantener su posición.

Con respecto al driver. Lo has tostado del todo? Es decir no funciona nada el motor que controla ese driver?

Si es solo el zumbido, es algo completamente normal y sonará más cuanto más corriente hagas circular por el motor.
Logged

   

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola de nuevo, he intentado probar tu programa ngc1300, pero debo de tener algun proble en mi pc. estavez no he conseguido car ni el firmware y si tu programa. Pero vamos que mas tarde otemprano lo conseguiere, soy un poco ¡cabezón!
El funcionamiento de mi CNC aceptable... Tenías razón, el eje X estava cambiado por el Y y claro no funcionaba bien. no obstante adjunto foto de dos de los gcode que viene con Txapuzas para ver si me podeis decir que esta pasando ahora con la CNC.

Por cierto ngc1300, con tu programa la primera vez que lo intente fue con el gcode de Txapuzas. Todavia me queda mucho para poder hacer los mios y cuando los realice seran con Inskape, parece el mas facil no¡


Gracias por tu ayuda. Cuando consiga que esto funcione mas o menos me planteare los drivers de fm o los de esteca 55 no ya os pedire consejo.

no se ve del todo mal, puede que estés perdiendo algún paso, pero prueba a fresar algo, ya que yo cuando tenia los l298 las pruebas con lápiz salían perfectas y cuando fresaba era un desastre y perdía muchos pasos.

yo uso el artcam para generar los gcode con el formato flexicam, probare a meter los gcodes que vienen con el programa de txapuzas a ver, aunque deberían funcionar bien ya que no cambia gran cosa de un formato al otro.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Por cierto ngc1300, con tu programa la primera vez que lo intente fue con el gcode de Txapuzas. Todavia me queda mucho para poder hacer los mios y cuando los realice seran con Inskape, parece el mas facil no¡

He mirado que es lo que ocurría con los gcode de Inskape y parece que hay un problema con los números de linea y el hecho de tener varios comando G en la misma linea, lo corregiré y en cuanto lo tenga subo una nueva versión.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Al final me volví a descargar los archivos gcode del programa de txapuzas y lo que había visto al principio no era del todo correcto, seguro que confundí el archivo con alguno de los muchos que genere cuando empece a usar el artcam.

En principio los archivos que hay en el programa de txapuzas tienen el problema de los comentarios que mete el inkscape, si se los quitas deberían de funcionar perfectamente mientras arreglo el problema.
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Desde que vi el paperduino pensé en hacerme uno para ponerlo en la cnc y poder usar el arduino para otras cosas, con lo que compre un chip en china y después de mucho esperar al final llego, jajaja. Cuando empece a ver como podía hacer el paperduino para fresar la pcb con la fresadora, pensé que estaría bien que pudiese poner la chapuza de shield que me hice en su día, luego pensé en que también podía hacer otra vez la shield bien hecha, al final pensé en que ya puestos porque no hacerlo todo junto, siguiendo pensando porque no meter el paper rele y preparar para tener los finales de carrera (quiero meter en el software una opción para que la maquina encuentre sola los limites y se posicione donde le digamos, las esquinas o el centro.) con lo que al final me he hecho un esquema de como tendría que ser todo junto (mas o menos como una sanguinololu pero en fresadora), a excepción de la conexión serial que seria mediante el cable de nokia o el paper rs232 lo que encuentre antes.

Os pongo todo el lió que he hecho a ver si algún entendido me tira un cable y mira a ver si no he metido mucho la pata.

Entiendo que es un tema complicado y difícil, pero por intentarlo no se pierde mucho solo una pcb y si queda bien la verdad es muy cómodo tenerlo todo integrado.


* esquema.png (43.31 KB, 2148x1188 - viewed 83 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 4
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Buenas de nuevo FM

Este finde he realizado pruebas con los motores y tu drivers, pero se movían como a saltos y uno se me tostó, des pues de darle tropeciantas vueltas vi que el regulador de la corriente (el tonillito) tenia la chapita hacia la derecha del todo.

Otra cosa que he detectado es que cuando se mueve un motor a veces repercute en el resto, incluso se escucha un pequeño zumbido.

Alguna posible solución a esto, eso si aparte de volver a pillar un driver, jeje
El zumbido que escuchas es de la corriente recirculando por las bobinas de los motores. Es algo que no lo hacen los lineales (basados en el ULN) porque no hacen ningún control de corriente activo. Ese zumbido debe desaparecer en el momento que pones el pin de ENABLE a HIGH.

Porque suenan los motores cuando solo mueves uno, basicamente porque aunque no se estén moviendo, si que están trabajando para mantener su posición.

Con respecto al driver. Lo has tostado del todo? Es decir no funciona nada el motor que controla ese driver?

Si es solo el zumbido, es algo completamente normal y sonará más cuanto más corriente hagas circular por el motor.


OK

Sobre el pin no lo puse, jeje, me podrias decir donde localizarlo

El driver si esta tostado, el chip tiene un punto negro, aunque viendo donde se produjo, puede que fuera por el desipador que le puse, ya que se calentaban demasiado.

Te pediré un par de drivers por si las moscas, jeje
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 88
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Como lo prometido es deuda, dejo unas imagenes para que veais lo bien que va la electrónica de @fm. Y la verdad que la maquina me ha quedado bastante bien.
Pongo lo que lleva:
Realizada en Fenólico
Motores Nema17
Electrónica @FM
husillos diam. 16 Paso 5
barras diam. 16

Y ahora las fotos de una PCB realizada ayer




Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 88
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hay una cosa que no he encontrado.

El circuito lo he hecho en eagle y luego utilizando el script pcb-gcode. He puesto un plano de masas y luego he prohibido que se haga el plano en diversos sitios de la placa, pero no he encontrado que la cnc se coma el  cobre que está fuera del plano de masas.
Sabeis la forma de hacerlo???

Un saludo
Logged

Pages: 1 ... 71 72 [73] 74 75 ... 78   Go Up
Jump to: