Pages: 1 ... 75 76 [77] 78   Go Down
Author Topic: Montaje CNC, calibrar ejes configuración y software  (Read 177420 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola que tal a todos , primeramente felicitarlos por ayudarnos a continuar a  todos los que queremos montar nuestras CNCs con los materiales basicos y mucha imaginación.

Como no , tengo problemas en mi CNC y no puedo encontrar el error , ya que estoy con toda la electronica montada , (fuente , pololus y motores) y haciendo pruebas , lo mas importante está conseguido, todo funciona ! PERO tengo el problema que el eje X dá microsteps , pequeños giros luego de ejecutar el comando Z 1:0 , al parecer sigue bajando sin control , he probado a cambiarlo de lugar (los pines de arduino ) y sigue en lo mismo.

No sé como solucionar el problema, asi mismo he cambiado la forma de hacer los archivos NGC mas pequeños y eso no es el problema.

Si alguien sabe o ha tenido el mismo problema, por favor , que me diga por donde empezar a rebuscar .

Tengo cargado el sketch reprap_new_firmware porque fué con el unico que pude hacer girar los motores con txapucnc. , los archivos de txapu rx pololu no me funcionan, inclusive cambiando el orden de pines en mi arduino.

desde ya muchas gracias a todos .
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Solucionado mi problema.

El eje Z deja de bajar si en vez de utilizar un codigo , por ejemplo:

G01 Z-1.000000 F100.0
G01 X18.374808 Y51.238750 Z-1.000000 F400.000000
G01 X24.549471 Y49.584253 Z-1.000000
G01 X23.401639 Y45.300478 Z-1.000000
G01 X17.226977 Y46.954969 Z-1.000000



utilizo este :
G01 Z 0.0000 F 100.0000
G01 X 3.2900 Y 54.8491 Z 0.0000 F 100.0000
G01 X 29.0522 Y 54.8491 Z 0.0000
G02 X 35.8420 Y 54.6830 Z 0.0000 I -0.0017 J -138.9459
G02 X 39.4409 Y 54.3407 Z 0.0000 I -1.9241 J -39.3183


Hago bajar el ejeZ lo que me apetezca , pero siempre trabajando sobre Z 0.0000.

saludos
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Como les va, les cuento estoy realizando una cnc casera siguiendo la web de txapuzas.
Tengo una duda que no logro resolver (sacando cuentas ,etc).
Es sobre los motores de mi maquina.
Arranque con unos nemas 17 que obtuve de varias impresoras (todos diferentes).
Como driver utilizo el driver chino ln298.
Claro esta al ln298 si lo alimento a mas de 5v se calientan demasiado.

Con respecto  a los motores, logre cambiarlos por 3 nema 23 identicos.
Estos trabajan a 2.4v a 1.5A .
Los ln298 siguen calentando, investigando vi que estos chips son obsoletos y no tienen control de corriente, por eso se los debe usar con el l297.

Aqui las cuentas no me cuadran, por que calientan los driver?, si los motores estan dentro del consumo optimo.

Por otra parte ya no voy a renegar y comprare 3 driver a4988 de pololu . Funcionaran?.

Saludos a todos !
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Muy buenas a todos, me presento, soy Alex de A coruña y quisiera pediros un poco de ayuda, que ya no se por donde tirar. smiley

Recién empiezo con esto del arduino y la CNC y estoy teniendo los siguientes problemas, tanto con el soft que ha hecho un miembro de esta comunidad como con el Txapu:

 - Hago pruebas de dibujar y las letras me salen deformes, empieza bien, pero luego sale deforme.
 - Los drivers se calientan una barbaridad, he probado a ponerle el firmw de fm (creo que es ese, el mismo que está en la web del proyecto del software) al arduino, pero ahí la máquina no responde y los driver se calientan todavía más.

Decir que uso un Arduino UNO y los drivers son los L298n (chinos).

Los motores son Nema 17 (estos para ser más exactos: http://www.ebay.de/itm/Nema17-Stepper-Motor-1-7A-0-9Degree-48mm-length-17HM5417-3D-Printer-Parts-RepRap-/200969211489?ssPageName=ADME:X:RTQ:DE:1123 )

Los motores como veis, son motores de 0,9º, esto no ha sido problema, pues sólo hay que recalcular los pasos x mm, lo que me preocupa un poco más, es la alimentación, en principio están a 12v y 5v para los driver, pero según el vendedor de los motores pone Rate Voltage: 3,06 ¿? Aquí me he perdido, sólo sé que si los alimento con 3,5V la fuente cae.

Perdonad mi ignorancia si he dicho alguna tontería.

Gracias!
« Last Edit: January 16, 2014, 11:16:47 am by Spirit981 » Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 41
Posts: 2182
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

La deformación viene por pérdida de pasos ya que el driver corta por sobre calentamiento.
Logged

   

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Creo que los driver acaban de pasar a mejor vida smiley-sad , los motores ya no responden.

Que driver debería usar pues?

Gracias por la rápida respuesta
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Si quieres unos buenos drivers y no complicarte la vida, compra los de fm que calidad-precio están muy bien, a mi me solucionaron los mismos problemas que tienes tu.

Un saludo.
Logged

0
Offline Offline
Newbie
*
Karma: 0
Posts: 4
Arduino rocks
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Los l298n solo me dieron dolores de cabeza para la aplicación que les quiero dar ya que los que tengo son los chinos sin el l297.
Me di cuenta que solo retrasaba la construcción de mi maquina.
Consegui 3 pololu a4988 y se solucionaron los problemas que tenia (perdida de pasos, torque, calentamiento).
Adjunto unas imagenes del porta driver que realice. Hasta el momento funciona muy bien.




* 1044644_10151929777658348_1216792182_n.jpg (96.98 KB, 640x480 - viewed 119 times.)

* 1014375_10151929777908348_478462278_n.jpg (97.19 KB, 640x480 - viewed 80 times.)
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Los A4988 los tengo también, no los puse por vagancia de hacer el pcb o la placa como tienes tu (que por cierto tiene buena pinta), en cuanto a los de fm... verás... he buscado a ver donde podía comprarlos, pero no los encontré  smiley-red

Me auto-respondo, ya los encontré (he pasado varias veces sin verlos, sorry)

« Last Edit: January 21, 2014, 10:01:28 am by Spirit981 » Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yo los pololu los tuve, y uno se quemo, cuando los tienes a mas de 1 A sufren mucho, yo actualmente tengo los de fm a 1.6A sin ventilación y va de maravilla
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

He escrito un mail a la web, son los ELFDRV3, no? Se ve que se está reponiendo Stock o algo, también he visto la SAV Mkl que seguramente pida en breve para otro proyecto.

Gracias por los consejos
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 10
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, a esperas de que lleguen los afamados drivers de @fm (por cierto, gracias por la atención recibida), sigo probando, ahora con los A4988 que tenía por aquí. Con el txapu CNC me responden bien a medias, muevo en manual a la derecha y si, se mueve, pero pulso a la izquierda y sigue moviéndose hacia la derecha, tengo que esperar unos segundos y luego pulsar a la Izquierda, en cambio con el soft que se está desarrollando aquí nada, giran siempre hacia el mismo lado.

Alguna idea?
Logged

Offline Offline
Full Member
***
Karma: 2
Posts: 227
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

como los tienes conectados?, tienes bien configurado el firmware con el numero de pasos y micro step de los motores y drivers? que firmware usas?, me da que es un problema de configuración o de cables, si configuras mal los pasos de un motor puede hacer cosas raras ir a izquierda cuando le das a derecha o ir alternativamente a izquierda y derecha. Los programas no distinguen entre derecha o izquierda, solo mandan la posición a la que quieren que vaya.
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, a esperas de que lleguen los afamados drivers de @fm (por cierto, gracias por la atención recibida), sigo probando, ahora con los A4988 que tenía por aquí. Con el txapu CNC me responden bien a medias, muevo en manual a la derecha y si, se mueve, pero pulso a la izquierda y sigue moviéndose hacia la derecha, tengo que esperar unos segundos y luego pulsar a la Izquierda, en cambio con el soft que se está desarrollando aquí nada, giran siempre hacia el mismo lado.

Alguna idea?

Si los quieres mover de forma manual con Txapucnc , cada vez que apretes para mover por ejemplo a la izq un paso, y el siguiente a la derecha , verás que siempre tiene que volver al CERO (0) para moverse a la derecha. Si por ejemplo estas en X = 4 (derecha), apretas el boton HOME y puedes mover a la IZQUIERDA.

No es logico , pero a mi me pasa eso jaja. y en principio funcionan bien, yo creo que es mas un fallo del programa que de los A4988
Yo he logrado hacer que funcione después de muucho pelear, asi que sigue probando.

saludos
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 17
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Que post tan interesante. Esta mañana me lo he leído de inicio a fin y me he animado a montarme un cnc casero. He empezado a comprar cosillas y espero que pronto pueda empezar a poner fotos del montaje y tal. Ya os adelanto que me asaltan muchas dudas y que abusaré de vuestros conocimientos y experiencias previas.

Un saludo y muchas gracia
Logged

Pages: 1 ... 75 76 [77] 78   Go Up
Jump to: