Pages: 1 ... 34 35 [36] 37 38 ... 78   Go Down
Author Topic: Montaje CNC, calibrar ejes configuración y software  (Read 147411 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 28
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola cuchara, la verdad es que no son nada caros estos que me enseñas, yo todo lo que he mirado ha sido por tiendas españolas, para los motores si que mire por ebay y vi que habia muchos de china, pero no pense en los rodamientos, ahora ya es demasiado tarde, lo tendre en cuenta para una proxima cnc, si es que la hay  smiley


Logged

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, doy por finalizada la construccion de la fresadora. Con su ultima fase completada, correspondiente a la rectificacion de la base de trabajo para dejarla a nivel y cuyo trabajo ha sido extremadamente largo, se acabo. Ahora ya, a disfrutar(bueno, me falta hacer la caja, que tengo la madera ya en casa cortada).

A la semana que viene os podre alguna foto, pues no dispongo de camara, y la del movil es una elegante basura.

Agradezco a todos la ayuda y comentarios aportados, asi como de los debates sobre que usar o como hacerlo y sugerencias. Y a @Fm por el estupendo trabajo que ha realizado con la electronica, la cual lleva ya casi 48 horas de funcionamiento y sin ningun problema.

Apartir de ahora, empezare un nuevo diseño de una nueva maquina un poquito mas grande, teniendo en cuenta todos esos detalles que se han pasado por alto, o las mejores opciones para la construccion, y subire resultados por aqui smiley

Saludos y animo a los que esten en proceso.
Logged

Offline Offline
Full Member
***
Karma: 0
Posts: 117
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Hola cuchara, la verdad es que no son nada caros estos que me enseñas, yo todo lo que he mirado ha sido por tiendas españolas, para los motores si que mire por ebay y vi que habia muchos de china, pero no pense en los rodamientos, ahora ya es demasiado tarde, lo tendre en cuenta para una proxima cnc, si es que la hay   


Perdón, elimine mi comentario anterior ya que los rodamientos lineales que te mostré eran probablemente muy pequeños y su precio aumenta en cuanto al tamaño.  pero si buscas por aquí:
http://www.ebay.com/sch/i.html?_sacat=0&_nkw=linear%20bearings&_sop=15
 
bueno pues será para alguien mas.
Logged

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

La felicidad ha durado poco, ahora no logro hacer una linea recta, salen como curvitas y al fresar pcb, me deja rebaba en el cobre, que antes no lo hacia. No es problema de soft, ni de los motores, pues incluso he desconectado 2 de los 3. Ya no se si es problema del chasis o de la multiherramienta, y me inclino mas por esta ultima opcion.

Materiales blandos como el contrachapado, el grabado lo hace bien, pero si pasamos a Dm que es mas duro ya empieza a falla, y si seguimos subiendo y pasamos a una pcb (fibra+cobre) pues aun se aprecia un poco mas.

Opiniones y sugerencias. Hasta hoy, todo ha salido bien.
Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 38
Posts: 2173
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Pues si no has cambiado el SW de control ni la electrónica entre las pruebas es posible que tengas holguras en los ejes?
Logged

   

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Es la otra posibilidad que barajo, pero lo que no me gusta es el sonido que hace nuevo, y es que tiene una vibracion nueva, y viene de la multiherramienta(no es por holguras en algun eje, y solo sale cuando esta trabajando con carga, en vacio nada de nada). He comprobado todo, y esta como siempre. Hacer un surco de 4 decimas de ancho y una de profundo... no tiene porque ser un problema.

Problema de electronica y SW no es, pues incluso he probado hacer desplazamientos a mano. El material blando, cero problemas, y conforme es mas duro, empiezan a salir, y es de ahora que en las primeras andadas, no habia ningun problema.

Si son cortes de piezas, tampoco hay problema. Aunque exista ese nuevo defecto, no influye. Pero al hacer grabados en materiales un poquito duros...
Logged

Málaga, Spain
Offline Offline
Edison Member
*
Karma: 38
Posts: 2173
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

Puede que el eje del taladro se haya des equilibrado?
Logged

   

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

No gira perfecto eso si que es verdad
Logged

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Igual si que era problema de holguras. He apretado un poco el eje Z y el X, y ha mejorado. Eso si, me sigue saliendo rebaba, y eso no creo que sea ya problema de holguras.

El lunes igual me paso a por una multiherramienta nueva a ver.

Saludos
Logged

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, ya se donde esta el problema exactamente, y es en la multiherramienta, pues por lo que sea, en el portabrocas no queda bien alineada la fresa y tiene un desplazamiento.

Creo que terraguea le ponia algo a las herramientas para que queden mejor fijadas.
Logged

Sabadell
Offline Offline
Sr. Member
****
Karma: 4
Posts: 252
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Bueno, ya se donde esta el problema exactamente, y es en la multiherramienta, pues por lo que sea, en el portabrocas no queda bien alineada la fresa y tiene un desplazamiento.

Creo que terraguea le ponia algo a las herramientas para que queden mejor fijadas.


Wuenas,hummm, creo recordar que colgué hace unas semanas una solución casera para evita la excentricidad radial de las brocas o fresa que hiciese menos grueso que el interior del portaherramientas, colocando unas cánulas en su extremo.

De todas formas asegurate de tener las revoluciones adecuadas de la fresadora, a diferentes materiales diferentes revoluciones así como diferentes brocas.
Ah y que el orificio porta-fresadora ( la Skill vamos ) no tenga algo de holgura y que al forzar el trabajo a realizar desplace algo su eje, vamos, que tenga "juego"
Un saludo


* truco para dar diámetro a brocas.jpg (36.2 KB, 640x480 - viewed 33 times.)
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hola a todos! mi nombre es Emiliano y estoy hace rato estudiando tanto a este foro como a la pagina de txapu y otras, realmente sensacional el trabajo que estan haciendo!

Me fabrique una Mantis, con algunas pequeñas modificaciones, ya que pretendo usarla para trabajar con tablas de madera balsa ( el eje x mide unos 50cm). Use unos motores de impresora y la logica la hice con un arduino nano v3, un paper-rele y tres paper-stepper basados en el ULN2003, alimentado el arduino con usb y los drivers con 12v (fuente pc). Los motores calientan bastante pero parecen soportarlo bien, los he hecho trabajar durante varias horas de corrido y ningun problema. Los ULN no me calientan tanto, solo uno calentaba muchisimo por lo que coloque un fan de pc de los chiquitos, de todas maneras se quemó y lo remplace por uno nuevo, el cual casi no calienta (ahora los tres calientan poquito y los tres por igual, que con el fan se mantienen fresquitos), se ve que el quemado venia medio fallado, no lo se. El soft es el de txapu cnc, tanto el TX como el RX, a este ultimo con las modificaciones propias del calibrado de mi máquina. Los gcode los hago con Inkscape y gcodetools.

CONSULTA: las lineas rectas las hace perfecto, incluso de la medida correspondiente, tanto horizontales, verticales y diagonales. Pero las curvas no, intente varios tipos de curvas y nada, siempre tienen alguna distorsión, y aparentemente en el eje X. Por ejemplo al hacer un circulo, de forma simple, en el txapucncTx aparece el trazo de forma correcta, incluso probe armar el codigo de diferentes formas y eso responde perfecto, pero al darle play, el trazo dibujado por la maquina nunca cierra el circulo de forma correcta. Al terminar el trazo la herramieta (por ahora una fibra) nunca llega al punto donde comenzó, siempre queda un milimetro o dos desfasado en el eje X.

Espero su consejo, voy a seguir haciendo pruebas, pero no se que mas tocar. Me resisto a creer que es un problema del RX, y me inclino por pensar que el seteo de los pasos por milimetros del X o del Y tienen el error, pero cada vez tengo mas dudas.

No los aburro mas! y pronto trataré de colgar algunas fotos de mi proceso! que gracias a ustedes pude hacerlo en menos de un mes y ya la tengo andando!

 
Logged

Offline Offline
Sr. Member
****
Karma: 4
Posts: 371
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

A mi me pasaban esas cosas cuando por primera vez probe hacer algun dibujo poniendo un lapiz en el eje Z. Como no estaba bien sujeto, tenia holgura, y al llegar al final del proceso, no cerraba por un pelo.

Supongo que si por ejemplo haces un cuadrado, tampoco te lo cerrara.

Verifica los resultados de la maquina con un calibre.

Saludos
Logged

Offline Offline
Jr. Member
**
Karma: 0
Posts: 66
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Grafisoft: Antes que nada gracias por responder! y si, efectivamente un poco de juego tenia y controlar eso hizo que mejorara el resultado.
sin embargo sigo con problemas en las curvas. Hace cuadrados y triangulos perfectos, tanto las medidas como los trazos son exactos a como quisiera. Pero los circulos salen con forma de huevo, comienza el trazo en el lugar correcto y vuelve al mismo punto sin problemas pero al medirlo (a simple vista se nota) el ancho del circulo tiene unos 3 o 4 milimetros menos, mientras que en el eje Y tiene la medida correcta.
Trate de escribir el codigo de diferentes formas para ver si advertia cambios y no. lo raro es que repito los dibujos y siempre los hace igual, lo cual no deberia pasar si fuera por holguras no? en realidad no se je.
El error aparece siempre que hay un trazo curvo, mientras que con los rectilineos anda de diez!
Voy a ver si puedo refinar aun mas las tolerancias pero si se les ocurre alguna otra idea por favor diganla!

las fotos todavia se las debo, porque no se como ponerlas por el momento je
Logged

Sabadell
Offline Offline
Sr. Member
****
Karma: 4
Posts: 252
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

@ Animbius;

Por lo que dices la deducción más lógica es que tengas un problema mecánico o electrónico, vamos por partes:
Dices que los cuadrados salen perfectos, para los cuadrados no intervienen a la vez los ejes Y y X a la vez, ni tan siquiera cuando llegan a las esquinas, ya que se detiene uno y empieza el otro.
El problema es cuando trabajan los dos ejes a la vez ( el X y el Y )y dices a que en lugar de circulo sale un elipse, creo que todo apunta a una perdida de pasos en los motores.
Si te fijas en cual de los dos ejes trabaja mal encontrarás la respuesta, el eje que trabaja mal es el que en lugar de curva realiza un arco.
Fíjate en cual de los dos se calienta más, eso querrá decir que trabaja en condiciones más forzadas por tener desalineamiento o bien de la varilla métrica o de su acople.
Repasa las condiciones mecánicas en las que trabajan los ejes para que al menos sean iguales.
En la parte electrónica es más complicado ya que dices que utilizas motores de impresora reciclados, son los mismos motores???? del mismo voltaje???
Teóricamente deberían de moverse al recibir la instrucción, pero, a saber como les repercute la carga de trabajo a cada uno después de energizarse, pueden estar recibiendo más voltaje del necesario, produciendo sobrecalentamiento en unos más que en otros.Te diría que todo apunta a perdida de pasos en algún motor más que en otro, en concreto dices que en el eje X.
Es una idea, a ver si acertamos.

Para colgar fotografías yo clico en Additional Options y en examinar encontrarás la carpeta del disco duro donde tienes la foto, la clicas y ya está, en caso de querer subir más fotos pues ( more attachments ) smiley-wink

Un saludo

« Last Edit: October 03, 2012, 03:32:47 am by Terraguea » Logged

Pages: 1 ... 34 35 [36] 37 38 ... 78   Go Up
Jump to: