Go Down

Topic: optocouplers and resistors in camera flash trigger (Read 2281 times) previous topic - next topic

Hi!

I'm making a camera flash trigger, and it's working quite well. But there is one thing that bothers me.. 

I use an optocoupler (it says "EL 817 A105" on it) to short-circuit the cable to the flash so that it flashes. In the tutorial I'm following they connect the optocoupler from digital 12 via a 10k ohm resistor and one connection to ground. When I do this my flash wont trigger, but when I put the cable directly to the optocoupler without the resistor it works.

Could this damage the optocoupler?

The other thing is, when i tried this with studio flashes it stopped working when i raised the output on the flash, why is that? Is it not just a short-circuit that fires the flash?


John_S

The drive side of an optocoupler is an LED. So 10K might not let enough current through to fully turn it on. I would try 1K, if that doesn't work, try 330 or so. Connecting an optocoupler directly to the digital pin will damage it.

I'm not sure about studio flashes. It might be a larger voltage than the optocoupler is rated for.
http://jsrintervalometers.blogspot.ca

mmcp42

I use 330 ohm resistors for powering my opto coupler
it fires flash (and shutter and focus) perfectly
a) check the data sheet to see what max current the LED side will take
b) you do have it the right way round? :)
there are only 10 types of people
them that understands binary
and them that doesn't

AWOL

MOC3020 optotriac is good for up to 400 V, which should be ok even for studio units.
I have Vivitar 283s with triggers up to around 180v, which work fine with these devices.
"Pete, it's a fool looks for logic in the chambers of the human heart." Ulysses Everett McGill.
Do not send technical questions via personal messaging - they will be ignored.

Thanks! I tried with a 330 ohm and it works fine!

I think I will use my speedlight, and if i will be in the studio i will put the studio flashes in slave mode, since I don't have enough time to buy MOC3020 optotriac.

I'm quite a noob when it comes to electricity, but does the current become higher when you short-circuit the flash with a higher output, so you can destroy your optocoupler that way?

John_S

does the current become higher when you short-circuit the flash with a higher output, so you can destroy your optocoupler that way?
I would think it depends on the flash unit. The best way to figure that out is to check the voltage across the flash terminals at different output levels.
http://jsrintervalometers.blogspot.ca

mmcp42

most modern flash heads have logic-level triggers, so the amount of current taken is usually quite small

some older/Chinese/cheap units have typically 185 volts or more at the trigger
these definitely need a more robust approach

there are only 10 types of people
them that understands binary
and them that doesn't

SignorRossi

Hi,

this topic sounds quite similar to me, because I'm searching help for nearly the same issue.

I also want to trigger a flash (old Metz flash macablitz 214 L 28 R - real old piece, but still working, about 210V). When the flash is loaded a small , let me call it lamp, located on the backside gets orange...

I try to trigger the flash with a digital I/O of the arduino uno board via a PhotoMOS AQW210EH - just the same way, it's shown on YoutTube.

The tricky thing is, that the flash doesn't want to trigger, only the orange lamp on the backside of the flash turns off and imediatly after the signal from arduino is switch off, gets on. This is the same behaviour I do get, when I connect the two leads from the loaded flash to an e.g. 220Ohms resistance - no flash, only the orange lamp goes off.

I'm quiet new to electronics - theoretical knowledge, but a practivcal rookie... The last few days I tried to find a understandable solution for this problem, but I could'nt find one... some suggest an opt-coppler, some a src, some this, some that... can anyone out there give me a clear giudance to this topic?

Thanks for all the efforts in advance

SignorRossi


Link youttube video: http://www.youtube.com/watch?v=R8_dAgaBBdI[/sup]
Link Datasheet AQW210EH: http://www.panasonic-electric-works.com/catalogues/downloads/photomos/ds_x615_en_aqw21eh.pdf

jwatte


I'm quite a noob when it comes to electricity, but does the current become higher when you short-circuit the flash with a higher output, so you can destroy your optocoupler that way?


There are two currents -- the current from the Arduino through the optocoupler internal LED, and the current from the flash through the optocoupler internal phototansistor. These are not directly related.
Your job is to provide enough current into the LED so that the transistor opens fully and lets the current to trigger the flash through.
There are two voltage/current ratings for optocouplers -- one for what's needed/acceptable for the LED side (what you drive from the Arduino), and one for what's acceptable on the triggered side. As long as the voltage and current of the drawn trigger is not higher than the rating on the triggered side, you won't destroy the optocoupler. If you're worried, put in a series resistor on the triggered side, based on the voltage you observe and the current rating of the coupler.


rNmScale

@SignorRossi  Trig voltage of 210 wouldnt be a problem for MOC3020.

I have a few idea why your flash wont trigger but i am not sure at the moment. Try the following and reply here if it works (or if it doesnt ! )

If your flash is still working normally then try connecting a 0.1uF ceramic capacitor in parallel with a 1-2M ohm resistor to the two terminals of your flash unit. The capacitor should be rated at atleast 200V for safe operation. If you dont have one at that rating it would still might work but burnup after use.

If your flash still wont fire then then try connecting only the 0.1uf cap with your flash unit.

Go Up