Go Down

Topic: Arduino Duemilanove não recebe programas... (Read 1 time) previous topic - next topic

Comprei um kit do arduino no Ebay, com o Arduino Duemilanove com atmega328. Demorou mais de um mês para chegar, fui testar hoje e não consigo carregar os programas. Estou usando Windows 7 64 bits, o computador reconheceu normal o driver do arduino. Ele acende a luz de power e fica piscando o LED vermelho com um L escrito do lado (desculpe, sou meio leigo ainda no mundo dos arduinos!). Quando eu tento carregar algum programa só aparece isso:

avrdude: stk500_getsync(): not in sync: resp=0x00


Aguardo ajuda! Desde já agradeço.

mmoscz

Assumindo que vc configurou a IDE do Arduino para duelmilanove w/ 328, baixe o driver do  FTDI diretamente do site, pois alguns usuários tiveram problema com o driver que vem com o pacote da IDE do Arduino (eu tive esse problema)...

http://www.ftdichip.com/FTDrivers.htm


4x Duemilanove (clone)
Uno torrado (clone)
Amiga 1200 40MB
Windows XP

Como eu faço pra instalar os drivers do site? Quando eu conecto o arduino ele já instala os drivers automaticamente e quando eu boto para atualizar o driver a partir da pasta ele fala que já está atualizado!

mmoscz

O led vermelho "L", fica piscando o tempo todo, ou apenas pisca algumas vezes qdo vc liga o 2009?
Você pode fazer o teste dando o RESET manualmente no 2009, quando der o UPLOAD do sketch, aperte o botão de RESET do 2009 assim que aparecer a
mensagem "binary sketch size XXXXXXX". Talvez você esteja com um 2009 que não tem o auto-reset.
4x Duemilanove (clone)
Uno torrado (clone)
Amiga 1200 40MB
Windows XP

mmosz muito obrigado! Aparentemente era isso mesmo! Tenho q apertar o botão de reset pra ele receber o programa. O led L ficava piscando o tempo todo, provavelmente já estava com o blink gravado! Testei outros tempos do blink e funcionou perfeitamente, muito obrigado!

Go Up