Pages: [1]   Go Down
Author Topic: OSEPP Mega 2560 + Arduino Ethernet Shield question(s).  (Read 1330 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

I tried to make a board using the ENC28J60.  Due to not using exactly the right parts (but should have been "ok" IMHO,) not having the best scope, and not having the knowledge/experience <--- most important one. I ditched the project and purchased a Arduino Ethernet Shield from Radio Shack to at least see what is "supposed" to happen.  See what happens in Wire Shark, see what signals look like, the sequence of events etc...

I removed the ICSP female header and replaced it with a male header (just like the OSEPP and Arduino Mega 2560.)  I made a cable to interface with the existing circuit on my breadboard as it also uses SPI devices.  I also wanted the shield to sit in the breadboard as opposed to on top of the Mega 2560 so I could have better access to the USB and external power connections.

After several days and reading, re-reading, and scrounging for every bit of info (the hacks to bend pins on the shield including pin 10 on the shield, excluding pin 10 on the shield [ss/cs] in which I connected the ss/cs pin on the shield to pin 10 and 53 on the Mega 2560.)  I still could not get the example sketch to poll analog pins and feed that data to the web browser.

In frustration I went simple, and removed all other SPI devices and buffer ICs (74HCT244s) as the other SPI devices need 3.3vdc to work. and simply plugged the Ethernet shield into the Mega 2560.  I still used the breadboard to jumper the Mega's SPI pins to the Ethernet Shield and commented out "Spi.begin();" line out on my sketch as well.

I tried the my sketch again with the example code embedded and it worked, pings great... 

I know the problems could have been a bad connection on the bread board, or any number of other anomalies and oversights but I'm going to ask a couple questions to maybe have some more ammo when I start building my circuit bit by bit to see what breaks and where.

1.  Could/Does invoking the SPI library in my code AND what is done in the ethernet library cause problems?  I'd like to have explicit control of SPI.

2.  My external power supply is providing 3.3vdc to the breadboard and 7vdc to the Mega 2560 (it regulates that down to 5vdc.) plus I feed that 7vdc to a 5vdc regulator on the breadboard for everything else.  When the shield was in the breadboard I connected 5vdc to the 5vdc female pin, the grounds from the breadboard to the shield, the reset pin was connected to the Arduino, and the MOSI, MISO, SCK and SS (pin 10) on the shield were connected properly to the breadboard "in front" of the level shifting IC.  QUESTION:  I looked at the schematic and didn't see anything else that HAD to be connected.  Did I miss something? 

Thank you in advance, reading the posts and lurking has been a real benefit.

Freezerburn

Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
Could/Does invoking the SPI library in my code AND what is done in the ethernet library cause problems? 
It would have taken less time to uncomment the call to SPI.begin() and tested, than to post this, wouldn't it? Then, you'd KNOW (and so would we).
Logged

Offline Offline
Newbie
*
Karma: 0
Posts: 11
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Yes PaulS, you're right, but it was 5am, I had to sacrifice a significant amount of "progress" to gain what I have... So I'll spend the day rebuilding and solving old problems. 

So that is what I'll do now, and I'll also see if there is a way to ignore posts by you in the future as this isnt' the first worthless post I've seen of yours.  In fact I'm almost ashamed I bothered replying to you at all.
Logged

Seattle, WA USA
Offline Offline
Brattain Member
*****
Karma: 601
Posts: 48543
Seattle, WA USA
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Quote
I'll also see if there is a way to ignore posts by you in the future
I'll do the same for you.
Logged

Pages: [1]   Go Up
Jump to: