Go Down

Topic: une led qui s'allume juste avec du + (Read 1 time) previous topic - next topic

anthology

bonjour a tous
je suis en train de faire un essaie avec un triac et j'ai un soucis
j'ai une led brancher sur un triac
le triac est piloter via l'arduino
seulement le - de la led n'est pas brancher et elle est allumé quand même
avez vous une idée ? car la j'avoue tomber sur le cul
sur les photos le fil bleu piloter le triac et le fil jaune c'est le + venant de l'arduino
après aucun fils autre comme on peut le voir
merci a vous

al1fch

#1
Jan 28, 2012, 10:06 pm Last Edit: Jan 28, 2012, 10:08 pm by al1fch Reason: 1
en enlevant le triac elle s'allume encore ?
Si oui, ça devient intéressant !!
Si non il faut imaginer que le triac y est pour quelque chose et qu'il 'referme la boucle'...

anthology

nan quand j'enlève le triac elle s'éteint
mais c'est quand même bizarre ^^

al1fch

#3
Jan 28, 2012, 10:31 pm Last Edit: Jan 29, 2012, 09:25 am by al1fch Reason: 1
ça s'explique par la structure interne du Triac

Dans le Triac, entre A1 (à gauche ) et G (à droite) il y a l'équivalent de deux diodes tête bêche en parallèle avec une résistance d'une centaine d'Ohms, ça laisse passer le courant dans la led bleue.
(Globalement le Triac est l'association de deux Thyristors tête-bêche dont on aurait relié les gâchettes.)


http://michel.hubin.pagesperso-orange.fr/physique/comp_puis/chap_cp1.htm

anthology

ouep la dessus ok
par contre normalement une sortie pwm de l'arduino sort un signal carré avec du 5V
donc la j'alimente la led avec du 5V sur chaque broche
bizare

al1fch

signal PWM = créneaux entre 5V et 0V = successions rapides de +5V et de 0V....
La led bleue s'allume pendant les 0V et la persitance rétinienne fait croire à un allumage permanent...
En réduisant la valeur de reglage du PWM la luminosité de la led doit diminuer.

anthology

ok merci pour les infos
m'enfin bon ca fait toujours bizarre quand même ^^

Artouste


seulement le - de la led n'est pas brancher et elle est allumé quand même

si si   :smiley-mr-green:   la cathode est bien "branchée connectée"  sur une jonction de la breadboard  :)

refait la même expé/demo avec la cathode (repliée) en l'air   :)

anthology

oui connecté a la breadboard mais ya rien sur cet ligne ^^

Artouste


oui connecté a la breadboard mais ya rien sur cet ligne ^^



oui, oui j'ai vu/lu    :smiley-mr-green:  , mais fait l'expé "patte" déconnectée du breadboard  8)

anthology

quand la patte est déconnecté ca marche plus mais la c'est normal
par contre j'ai changé la pate ( de la led ) de la patte du triac
et la elle est eteinte ^^

al1fch

#11
Jan 28, 2012, 11:05 pm Last Edit: Jan 28, 2012, 11:08 pm by al1fch Reason: 1
Quote
par contre j'ai changé la pate ( de la led ) de la patte du triac
et la elle est eteinte ^^

si la cathode de la led a été reliée à A2 et non plus A1, il est plus difficile d'obtenir l'allumage de la led !!
(il faudrait au moins provoquer auparavant l'amorçage du triac et le maintien de cet amorçage...)
le Triac a une certaine symétrie qui lui permet de conduire les deux alternances du secteur mais la gâchette entretient quand même un rapport particulier 'de proximité' avec A1 !!

anthology

ouep je viens de capter avec les schema que ta mit avant ^^

chabot380

salut
J'ai pas tout compris ! :smiley-roll-blue:
c'est le triac qui commande la LED ? Le triac est alimenté en alternatif j'espère !
Sinon une fois amorcé il restera conducteur.

A+
chabot380
ORDINAUSORE 2Ghz AMD64 QUI S'ALLUME EN 48 SECONDES AVEC UBUNTU 12.04
ARDUINO UNO / Shield Ethernet / RTC DS1307
Programmation Python et j'apprends le C
Technicien Télé Vidéo à la retraite.

al1fch

#14
Jan 29, 2012, 09:19 am Last Edit: Jan 29, 2012, 09:45 am by al1fch Reason: 1
Bonjour
@chabot380
le triac n'est pas utilisé complètement (A2 en l'air, pas d'alternatif)
la led bleue peut s'allumer à travers la liaison interne entre G et A1 (une résistance et deux diodes)
(au multimetre [en ohmmetre] , sur un triac non monté on trouve généralement une résistance de 50 à 100 Ohm, dans les deux sens , entre G et A1. )

Le titre du fil ne convient pas vraiment car la cathode de la led est reliée à la masse à travers la liaison interne A1-G du triac et la résistance extérieure de gâchette .... pendant les états bas du PWM.On ne peut pas dire qu'il y a "juste du plus"...

Go Up