Go Down

Topic: Arduino Uno + Wireless proto shield + Wifly module (Read 15 times) previous topic - next topic

mc63

#25
Feb 14, 2012, 07:05 am Last Edit: Feb 14, 2012, 07:08 am by mc63 Reason: 1
The green LED(P104) blinks slowly meaning that its IP address is ok...if i may ask what is the response u get after pinging from the wifly terminal your gate away or host PC because for me am not getting any response (what does this mean?).....

To cancel the effect of unknown commands that may affect the performance of the device i applied factory reset command. I then sent the necessary commands to connect to my network. After successful connection I used the following commands
Code: [Select]

<2.23> set wlan ssid habs
AOK
<2.23> set wlan join 1
AOK
<2.23> save
Storing in config
<2.23> reboot
*Reboot*WiFly Ver 2.23, 04-26-2011 on 131C11
MAC Addr=00:06:66:14:a7:c7
Auto-Assoc Alhabsy chan=1 mode=WEP SCAN OK
Joining Alhabsy now..
*READY*
Associated!
DHCP: Start
DHCP in 50ms, lease=86400s
IF=UP
DHCP=ON
IP=192.168.1.9:2000
NM=255.255.255.0
GW=192.168.1.1
Listen on 2000


I also tried to do firmware update over ftp but i am getting the following response....
Code: [Select]

<2.23> set ftp user roving
AOK
<2.23> set ftp pass Pass123
AOK
<2.23> set ftp filename wifly-GSX.img
AOK
<2.23> ftp upload
<2.23> FTP connecting to 208.109.78.34
FTP timeout=2

<2.23> ftp update
<2.23> FTP connecting to 208.109.78.34
FTP timeout=2


dhunt

Since you do got a DHCP address, but then can't ping the gateway that the DHCP server gave the WiFly, I'd agree with sponder and guess that there's a network problem.

What kind of router do you have? Have you been able to use any other wireless devices with it ( laptop, smartphone, etc)?

sponder

Well, your laptop seems to be ok. (routing is correct etc.) Can you confirm this by pinging a smartphone or other laptop, which is on the same WLAN (and also got an IP address from the same DHCP server)? If this works without any problems, the problem must be the WiFly.
This is probably the case since the test the other way around also fails (letting the WiFly ping the gateway.)
I would first confirm it's not your laptop (by pinging another device) and if that's successfull, i would try a different another WLAN / router / network.
If your findings are the same on another network, i would contact Roving Networks support. You might have a defective unit.

mc63

I am using dlink router for my home network and I have other laptops n smartphones on the same network....so I tried pinging one of the PC's n smartphone but am getting da same result of "destination host unreachable"...The same thing happened when I pinged from one of the other PC's  . am going to try on another network
Sponder..what kind of response do u get when u ping your gateaway from da wifly?....this might help to compare with mine....

dhunt

Do you have the model number of the dlink router?

Go Up