Go Down

Topic: Arduino 0-10V PWM - KSQ (Read 3 times) previous topic - next topic

uwefed

#5
Jan 31, 2012, 03:38 pm Last Edit: Jan 31, 2012, 03:49 pm by uwefed Reason: 1
Außer, daß es 10 V sein sollten und nicht 12V, fehlt das RC-Glied das aus dem PWM Gleichstrom macht.
Grüße Uwe

riiin

Hi nochmal,
sorry, wenn ich mich so doof anstelle.
Wenn ich zwischen Netzteil und 1KOhm-Widerstand einen 2KOhm-Widerstand setze, lässt dieser doch nur 10V durch, richtig? So habe ich meine 10V. Kann ich dann den 1KOhm-Widerstand weglassen?
Und warum benötige ich ein RC-Glied, es kommt doch ein PWM-Signal aus dem Arduino und soll zur PWM der KSQ. Oder habe ich dann ein Problem mit dem BC547 ?
Danke schonmal.
Gruß Rene
Heute ist die gute alte Zeit von Morgen ;-)

Zaisow

So wie ich das verstehe wird deine Konstantstromquelle nicht mit PWM gedimmt sondern mit einer Spannung. Das RC-Glied macht aus dem PWM signal eine Gleichspannung

riiin

Im Moment habe ich den PWM-Ausgang direkt an der KSQ angeschlossen, das funktioniert. Also sollte es doch dann auch gehen? Mein Problem ist nur, dass das Dimmen nur von 0-50% geht, die Leds also nicht 100% ihrer Helligkeit entfalten. Der PWM-Eingang der KSQ zeigt 0-10V und der Arduino macht ja "nur" 0-5V, also brauche ich eine Lösung, um das Arduino-PWM-Signal mittels meinem 12V-Netzteil auf 0-10V anzugleichen. Ich möchte nur, dass ich mit dem Arduino die High-Power-Leds an der KSQ einfaden und ausfaden kann, was jetzt nur zu 50% funktioniert.
Ich hoffe, ich habe nicht unhöflich geschrieben.
Gruß Rene
Heute ist die gute alte Zeit von Morgen ;-)

Zaisow

PWM ist nur nicht 0-5 Volt sondern schnelles an und ausschalten von den 5Volt. Die Spannung zeitlich gemittelt ist dann 0-5Volt, grob gesagt das RC Glied sorgt für die zeitliche Mittelung des PWM signals. Eventuell ist in der KSQ schon ein Kondensator drin um Schwankungen am Dim Eingang aufzufangen.
An die Profis berichtigt mich wenn ich falsch liege.

Go Up