Pages: [1]   Go Down
Author Topic: Sure LED Matrix 24x16 Not Working with Arduino Uno  (Read 1285 times)
0 Members and 1 Guest are viewing this topic.
Offline Offline
Newbie
*
Karma: 0
Posts: 1
View Profile
 Bigger Bigger  Smaller Smaller  Reset Reset

Hello fellow Arduino users,

I recently bought the Sure Electronics 24x16 LED Matrix.
I used the matrix as shown in the tutorial here http://www.jacobpierce.com/blog/2009/10/11/arduino-hello-world-with-384-leds/ (I downloaded the ht1632 using the link the author provides). Additionally I tried the examples used in this tread http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1225239439 with no luck. I ensured that the ground +5V connections were not reversed so it can't be that the matrix is fried. Is there a chance that the unit that I have received is defective?

Information about my set up:
Board: Arduino Uno R2
IDE: Arduino 1.0
Power Input: 5V from Arduino board. The board is powered using a USB cable.

I can post the code that I used; the reason I haven't is because it would create a very long post.
Any help is appreciated.
Thank you in advance.
Logged

0
Offline Offline
Edison Member
*
Karma: 8
Posts: 1411
Arduino rocks
View Profile
WWW
 Bigger Bigger  Smaller Smaller  Reset Reset

This display may use HT1632C which has the initialization procedure a bit different.
Take a look at this post, it may help:
http://timewitharduino.blogspot.com/2011/10/difference-between-3208-and-0832-led.html
Consider all references to "3208" as "2416" for your case.
If it still doesn't work, check the wires between your Arduino and the display and make sure the pins are described correctly in your code.
Logged

Pages: [1]   Go Up
Jump to: