Go Down

Topic: Ethernet shield Question (Read 3 times) previous topic - next topic

lucadentella

Ciao

veramente strano... ma se colleghi qualcos'altro al router funziona? Che so due PC connessi in rete locale?
lucadentella.it

matrix77

#31
Feb 05, 2012, 10:24 pm Last Edit: Feb 05, 2012, 10:33 pm by matrix77 Reason: 1
Per adesso ho provato con dispositivi tipo convertitore USB/ETHERNET, oppure con un server video, sempre moduli configurabili, con indirizzi ip statici e vengono visti senza problemi; mi sono collegato anche con il portatile e anche in quel caso nessun problema.

Adesso ho riprovato con "arp -a" e funziona solo con switch collegato in cascata, visualizzandomi il mac della scheda, se poi collego lo shield al modem, l'arp è impossibile da trovare e la risposta del ping è "host non raggiungibile".

Se stacco lo switch, in cascata dopo che quest'ultimo è stato mappato dal modem e inserisco al suo posto lo shield, mi viene visto, ma  non devo spegnere niente, altrimenti è come se si smemorizzasse qualcosa nel modem e a quel punto dovrei "fregarlo", reinserendo lo switch, per poi toglierlo a "caldo" e così via...... da non credere eheh :smiley-roll:

Ciao

lucadentella

sembra che per qualche motivo lo stack Ethernet non piaccia al tuo router... prova a cambiare il mac address che hai assegnato ad Arduino e vediamo...
Se metti una arp statica su PC digitando

arp -s <mac-address-arduino> <ip-arduino>

funziona?
lucadentella.it

BrainBooster

Ma dai log del router non vedi nulla di strano?

matrix77

#34
Feb 06, 2012, 07:35 pm Last Edit: Feb 06, 2012, 07:39 pm by matrix77 Reason: 1

sembra che per qualche motivo lo stack Ethernet non piaccia al tuo router... prova a cambiare il mac address che hai assegnato ad Arduino e vediamo...
Se metti una arp statica su PC digitando

arp -s <mac-address-arduino> <ip-arduino>

funziona?
Ciao Luca, niente da fare:  "aggiunta alla voce arp non riuscita"

Questa cosa è un po' irritante, perchè significa che il chip d'interfacciamento ethernet dello shield, non garantisce il 100% di compatibilità coi

modem router, dal momento che svariati dispositivi connessi al mio modem, hanno funzionato, senza nessun problema.

Mi piacerebbe sapere a questo punto, quale alternativa si potrebbe scegliere, per avere un interfacciamento sicuro, allo stesso livello dei

prodotti venduti  "home consumer".


Ma dai log del router non vedi nulla di strano?
Salve Brain,

no, purtroppo è come se non esistesse lo shield collegato, ma ribadisco che la spia della LAN è accesa e lampeggia in concomitanza dello

shield stesso.

La cosa che non mi riesco a spiegare è del perchè, se inserisco in cascata lo switch, il mio modem lo "mappa", stacco lo

switch, collego lo shield al suo posto e da questo momento in poi, l'ip, risulta raggiungibile, salvo reset, di Arduino, o spegnimenti e

riaccensioni del modem, altrimenti si "smemorizza"questa ipotetica "mappatura" e addio indirizzo.... :0

Ciao

Go Up